locked
mangled stripped out Sharepoint websites RRS feed

  • Question

  • Guys I'm having a strange problem with a sharepoint website first off I had to rebuild our farm last week. So I create a new web app on the new farm than attach to

    the content database after that I pull the site up and a lot of the sites look like they've been stripped out even though they are inheriting the master page from the

    main site. I went in did a reset site defintion and even tried to reapply the master page however none of that worked. Let me explain stripped out a little more let's

    say you apply the default them to a site however instead of getting the default them you get a all white webpage and on top of that the text is severely out of

    position thats what I'm dealing with so if any one has any ideas please share.

    Monday, March 7, 2011 1:40 AM

Answers

  • Ok this was a pretty good problem it turned out that the core.css was not being applied this was also confirmed by using fiddler to debug the page. What was even more confusing was that certain sites in the site collection had no problem applying the core.css also all newly created subsites had no problem applying the core.css. Also if you took a stsadm export from a site where the core.css was not being applied than did a stsadm import to a blank team site the core.css would also not apply to that site. Below are the steps to resolve the problem

     

     

    1. Go to site actions site settings

    2.Go to look and feel section than select master page

    3. Go to where it says specify a css fill than paste this    /_layouts/1033/STYLES/CORE.CSS

    4. Than put checks in Reset all subsites to inherit this Site Master Page setting and Reset all subsites to inherit this system master page setting after that click ok to force these setting down

     

     

     

    • Marked as answer by agent200 Wednesday, March 16, 2011 11:36 AM
    Wednesday, March 16, 2011 11:35 AM

All replies

  • Hi aplhabanks,

    Thanks for your post.

     

    Here is the summary issue as I understand.

    Scenario: you have created a SharePoint 2007 site on your server. then you backup it and restore it to new farm using the “attach database” way. But as a result, the page seem to be stripped out. You have tried to reapplied the new master page to them, but it didn’t work still.

     

    1.       Have you customized the master pages before you backup them? Especially , have you put some files to the files system of the Web front server?

    2.       Have you tried to create new page based on the master page, and what’s the result?

    3.       Are there some error log when you backup and restore the files?

     

    Share your views.

    Thanks,

    Wayne

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    Monday, March 7, 2011 7:52 AM
  • Hi alphabanks,

    Would you please let us know how is your problem going? Is the suggestion helpful for your issue?

    If you need further assistance, please feel free to let us know.

     

    Thanks,

    Wayne

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

     

    Wednesday, March 16, 2011 1:42 AM
  • Ok this was a pretty good problem it turned out that the core.css was not being applied this was also confirmed by using fiddler to debug the page. What was even more confusing was that certain sites in the site collection had no problem applying the core.css also all newly created subsites had no problem applying the core.css. Also if you took a stsadm export from a site where the core.css was not being applied than did a stsadm import to a blank team site the core.css would also not apply to that site. Below are the steps to resolve the problem

     

     

    1. Go to site actions site settings

    2.Go to look and feel section than select master page

    3. Go to where it says specify a css fill than paste this    /_layouts/1033/STYLES/CORE.CSS

    4. Than put checks in Reset all subsites to inherit this Site Master Page setting and Reset all subsites to inherit this system master page setting after that click ok to force these setting down

     

     

     

    • Marked as answer by agent200 Wednesday, March 16, 2011 11:36 AM
    Wednesday, March 16, 2011 11:35 AM