locked
WP 7 package with PhotoChooserTask not working in newer versions RRS feed

  • Question

  • I have an relative old Windows Phone 7 application (XAP format) that uses the PhotoChooserTask to take pictures. After a longer period not updating the app (about a year) I recently did some changes based on user feedback. Now the certification failed due to an error taking pictures or importing them. That code hasn't been changed and a colleague did a test on his Windows Mobile 10 device and the app worked fine. I had one customer, using Windows Mobile 10, complaining that he couldn't use this function. So now I'm wondering what the reason for this could be?
    Thursday, March 16, 2017 8:15 PM

Answers

  • Hi Mattew.

    I was able to reproduce this. The name field in the application needed to be set. If that wasn't the case the capture task would start. I'm not sure why, but I added a default name when entering a new item and now it seems to work.

    Another thing that came up in the certification process is that there was no privacy url. I had added a privacy policy in the app, but I cannot find that url field. Maybe you have an idea where I should set this?

    Thanks

    Alexander

    • Proposed as answer by Mattew Wu Monday, March 20, 2017 2:31 AM
    • Marked as answer by AlexanderEsser Wednesday, March 22, 2017 7:46 PM
    Friday, March 17, 2017 7:11 PM

All replies

  • Hi Alexander,

    Could you share the specific error message in your certification failure report here?

    How does your colleague test your app, through deploying or sideloading the .xap package? And the OS version of his Windows Mobile 10 device?

    How about that customer who cannot use this function (old copy from Store or sideloading your new version package)?

    Additionally, you may also provide the core code that may reproduce this issue so that we can test it on our Windows 10 mobile device. 

    Thank you.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 17, 2017 7:29 AM
  • Hi Mattew.

    I was able to reproduce this. The name field in the application needed to be set. If that wasn't the case the capture task would start. I'm not sure why, but I added a default name when entering a new item and now it seems to work.

    Another thing that came up in the certification process is that there was no privacy url. I had added a privacy policy in the app, but I cannot find that url field. Maybe you have an idea where I should set this?

    Thanks

    Alexander

    • Proposed as answer by Mattew Wu Monday, March 20, 2017 2:31 AM
    • Marked as answer by AlexanderEsser Wednesday, March 22, 2017 7:46 PM
    Friday, March 17, 2017 7:11 PM
  • Hi Alexander,

    In this thread, we are mainly discussing about this issue(WP 7 package with PhotoChooserTask not working ) as indicated by your first post. Since it works now, you might mark that reply as answer.

    For your new question, it would be best if you would like to open up a new thread for it. I will try my best to offer assistance and it will make answer searching in the forum easier to other community members as well.

    Thanks for your understanding.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 20, 2017 2:31 AM
  • Hi Mattew.

    No problem. Thanks for the help

    Alexander 

    Wednesday, March 22, 2017 7:47 PM