none
Setup WCF service - log on problem RRS feed

  • Question

  • Hi every one

    I've a quite urgent problem and I need our advices!

    I have to create a setup which installs and registers a WCF service, but I've a problem in service log on after installation.
    I would like the service to start using the SO user credentials, but now the services uses the machine name.

    In this way my service doesn't access to database: the SO user can access db, but there isn't an user for the machine on database.

    Is there something to set in VS2010 setup project?
    Any advice?

    Thank you very very much

    Federica

    Wednesday, November 20, 2013 8:08 AM

Answers

  • Is there something to set in VS2010 setup project?
    Any advice?

    Hi,

    Yes, of cource.

    You should be able to run through the installation process. At the end of the process, you should have to fill out the ‘Set Service Login’ dialog. (If the install seems to have stalled, you may have to hunt around for this dialog – it has a habit of appearing behind other windows.), it may look like this:

    For more information, please try to refer to:
    #Creating a Setup Project for a Windows (WCF) Service with Visual Studio:
    http://joefreeman.co.uk/blog/2010/03/creating-a-setup-project-for-a-windows-wcf-service-with-visual-studio/ .

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, November 21, 2013 5:08 AM
    Moderator