locked
Unable to upload certificate to Azure Batch - "Cannot read property 'tbsCertificate' of null" error RRS feed

  • Question

  • I have created a self-signed certificate on my local machine, and exported it to a pfx file. 

    I want to upload this to my Azure Batch account. 

    When I select the file, and enter the correct password, and click Create, I get the following message:

    Cannot read property 'tbsCertificate' of null

    The certificate does not get uploaded. I can only click Cancel. 

    Is this because the certificate is self-signed? Or is there another problem?

    Mike

    Wednesday, December 18, 2019 10:42 PM

All replies

  • Hi,

    I searched for this error internally and got a possible workaround. Try that out and let me know if that helped you or not.

    Workaround is :

    1. Export the certificate with the 3DES-SHA1 algorithm.
    2. Upload the certificate to Batch Certificate

    If the workaround didnt work, We need to engage the support to get this solved.

    If you dont have access to Azure support, Send your subscription id to this email id

     AzCommunity@microsoft.com along with this thread id.  I can help you to create a one time free support.

    Friday, December 20, 2019 12:34 PM
  • The Export Certificate Wizard I am using (Windows Server 2016 Datacenter) does not have an option to specify the encryption algorithm. I don't see anything in the PS command Export-PfxCertificate for specifying an algorithm, and I don't know what property to look for with the Get-PfxCertificate object to see what algorithm the current file is. 

    Mike

    Friday, December 20, 2019 10:08 PM
  • Hi,

    If your issue is not yet resolved, Send your subscription id to this email AzCommunity@microsoft.com along with this thread url.

    I will help you enable a one time free support ticket to solve this issue.

    For the benefit of the community, Please post the answer here once your issue is resolved.

    Tuesday, December 31, 2019 12:46 PM
  • Hello,

    Any update on the issue?

    Thanks.
    Thursday, January 2, 2020 8:57 AM