locked
Store app works on dev platform but crashes on users

    Question

  • Hi everyone,

    I have a windows store app that I released about 8 months ago that worked well on my dev pc, my surfaceRT and a win8 laptop. After a few months, the last 2 systems started crashing on startup. Thought it was some sort of license problem. Didn't do anything at the time. Recently updated all my tools and did a fresh build and released it in the store. Uninstall and install on surface and laptop. Still doesn't work. Set up surface with remote debugging and launched from my dev PC. It worked perfectly. Uninstalled that ver from surface and installed fresh from store and it works. But uninstall from laptop and fresh install still crashes.

    Any ideas? There are no crash reports in dashboard but there is a comment from a user that it won't install. Seems more like a license issue. Maybe a rights issue with a local file? Why would connecting with remote debugger fix it? Maybe because the debugger makes me log in to my dev account?

    thanks for any suggestions

    Ken

    Sunday, May 4, 2014 1:57 AM

Answers

  • The things that come to mind as a possible cause for this are you are missing a permission in the manifest,  or you are not handling a setting or file not being there yet.
    Sunday, May 4, 2014 10:56 AM