locked
Running ASP Classic on II 10. How to solve error 404.15 query string too long RRS feed

  • Question

  • User1066906583 posted

    Hi, all!

    Last week We migrated a 2003 server to a 2016 server, moving IIS as well. Now, we are running IIS 10 with ASP classic.

    When performing some request, I got a 404.15 error: querystring is too long.

    I tried to use web.config witn no success.

    Anyone can tell me a suggestion how to solve this issue?

    Also, I don't know why, some request are not process by ASP Classic (an API). I don't know what is happening, because some times it responses very fast, and others doesn't.

    Thursday, May 28, 2020 6:30 PM

Answers

  • User-848649084 posted

    Hi,

    You could try to add the below code in the web.config file:

    <system.web>
    
       <httpRuntime maxUrlLength="10999" maxQueryStringLength="2097151" />
           
    </system.web>
    
    
    <system.webServer>
    
        <security>
    
        <requestFiltering>
    
          <requestLimits maxUrl="10999" maxQueryString="2097151" />
    
        </requestFiltering>
      </security>
    </system.webServer>

    Make sure you enabled the anonymous authentication. if it still does not work please try to run the failed request tracing for 404.15 error and provide that tracing result. 

    if possible please provide the sample URL which you are trying to cases and get this error. which application pool you are using integrated mode or classic mode. make sure you enabled the classic asp feature. try to use another browser that does the application behaves sam eon that or not.and to improve site performance in iis you could use output caching feature.

    Regards,

    Jalpa

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 29, 2020 2:22 AM

All replies

  • User-848649084 posted

    Hi,

    You could try to add the below code in the web.config file:

    <system.web>
    
       <httpRuntime maxUrlLength="10999" maxQueryStringLength="2097151" />
           
    </system.web>
    
    
    <system.webServer>
    
        <security>
    
        <requestFiltering>
    
          <requestLimits maxUrl="10999" maxQueryString="2097151" />
    
        </requestFiltering>
      </security>
    </system.webServer>

    Make sure you enabled the anonymous authentication. if it still does not work please try to run the failed request tracing for 404.15 error and provide that tracing result. 

    if possible please provide the sample URL which you are trying to cases and get this error. which application pool you are using integrated mode or classic mode. make sure you enabled the classic asp feature. try to use another browser that does the application behaves sam eon that or not.and to improve site performance in iis you could use output caching feature.

    Regards,

    Jalpa

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 29, 2020 2:22 AM
  • User1066906583 posted

    Thank you very much for youe help.

    Yes, I have the web.config file like you suggested me, with no success. I checked the application pool and it was not ASP Classic. I changed it, and I solved the problem. Also, the speed of the response, and now, I don't suffer any hang.

    Friday, May 29, 2020 6:29 AM
  • User-848649084 posted

    If your issue is solved then I request you to mark the helpful suggestion as an answer. This will help other people who face the same issue.

    Friday, May 29, 2020 6:37 AM