locked
Microsoft.WindowsAzure.Storage already has a dependency defined for Mircosoft.Data.OData RRS feed

  • Question

  • I'm using VS2010 with .net 4.0 and have an asp.net mvc project that contains both a web role and worker role for the azure platform.

    I'm trying to update my Azure.Storage package and get the following ..

    enter image description here

    I've noticed when I look at references in my project and look at the Storage it says it's vers 4.3.0.0. When I look in my packages.config (for both web and worker) it has.. 

    I can't find any reference to OData.

    When I've tried to install or update OData via he package management console it comes up with the same message of "...Storage already has a dependency defined for Microsoft.Data.OData".

    I've looked around and couldn't find a posting with the same error and also this is the first time I've tried updating packages so I'm unclear on the overall process.

    I have some code in my web role that apparently needs to reference the latest Storage package.

    thanks,


    :)

    Tuesday, December 2, 2014 10:13 AM

Answers

All replies

  • Hi,

    Would you be able to check what version of Microsoft.Data.OData is already installed?
    In Visual Studio, In you project, You could right click on the reference tab and click on add reference.
    In the reference manager window, you could check all the sections for the references already added.
    Ones already installed would be checked.

    Regards,
    Malar.

    Tuesday, December 2, 2014 3:27 PM
  • Hi mattech13,

    For your issue,I suggest that you can try the suggestions below:
    Step1 : Uninstall  "Microsoft.Data.Odata "  from NuGet Package Manager

    Step2: Run " Install-Package Microsoft.Data.Odata   " in the Package Manager Console.

    Steps 3: Run the  " Update-package windowsazure.storage –version  4.3.0" in the Package Manage Console.

     

     

    Best Regards,

    Kevin Shen.

    • Proposed as answer by Manu Rekhar Sunday, December 7, 2014 3:26 AM
    • Marked as answer by Manu Rekhar Monday, December 8, 2014 3:38 AM
    • Unmarked as answer by mattech13 Monday, December 8, 2014 9:29 AM
    Wednesday, December 3, 2014 9:04 AM
  • Hi Guys,

    only just returning to this issue, so I've unmarked the response as an answer as I'm just going to try it out now.

    thanks,


    :)

    Monday, December 8, 2014 9:31 AM
  • Hi Guys,

    I'm failing at Step #1 here :)

    Trying uninstall using NuGet PM - the package doesn't appear.

    I have a web role (the one I'm trying to update) and a worker role.

    OData doesn't appear in uninstall PM or in the References.

    So I looked at the worker role. OData also doesn't appear in the uninstalll PM but DOES appear in the Referrences.

    Could there be some conflict between these two roles and references and packages etc?

    Anyway, I then decided to try and uninstall OData using the PMC. I tried both roles and got the following..


    :)

    Monday, December 8, 2014 10:08 AM
  • Sorry the last posting seemed to ignore the other images..

    So following straight on from the last posting...


    :)

    Monday, December 8, 2014 10:11 AM

  • :)

    Monday, December 8, 2014 10:11 AM
  • Just an follow on from my previous posts, I've uninstalled Azure.Storage form both roles and removed the references.

    When I try and run install OData I still get a dependency error...


    :)

    Monday, December 8, 2014 10:22 AM
  • Hi there,

    when I right click and add reference I get a window with tabs of .net, com, projects, browse etc. None of he contents of these tabs have any 'checked' column or indication that they are checked/not checked.

    I've added odata vers 5.62 tho and still get the same message of storage already having a dependency on odata.

    thanks,


    :)

    Monday, December 8, 2014 2:44 PM
  • Another update from me.

    I removed all reference to OData and Storage (references, packages, dll's etc) and also unloaded the worker role in case there was any conflict.

    This enabled me to install OData using the NuGet PM.

    I then followed your steps again

    #1 remove OData using PM > ok

    #2 install OData using PC > ok

    #3 update Storage using pc > as I had removed it I went for install rather than update and rather frustratingly it still gives the same error message as before


    :)

    Monday, December 8, 2014 4:44 PM
  • Hi,

    Have you tried updating Nuget to the latest version? (https://visualstudiogallery.msdn.microsoft.com/4ec1526c-4a8c-4a84-b702-b21a8f5293ca)
    Also,in order to directly install OData libraries, just look for ODataLib in your package manager.

    You could also try using Dependency Walker to resolve the dependency issue.

    Regards,
    Malar.

    • Marked as answer by mattech13 Wednesday, December 10, 2014 8:58 AM
    Tuesday, December 9, 2014 3:25 PM
  • Yes in fact Malar's suggestion was the solution - updating to the latest NuGet Manager fixed it.

    thanks,


    :)

    Wednesday, December 10, 2014 8:58 AM
  • I'm glad it worked. :)

    Wednesday, December 10, 2014 9:35 AM