none
Is my environment accurate for Printer Driver *.cat files certification RRS feed

  • Question

  • Hi.

    I new in this crazy underworld of Print Driver certification using HCK and HLK studios/controllers and I'm hoping someone can confirm or guide me in the right direction for efficiency.

    The OSs I run the WHQL certification tests are Windows 7 (x32/x64), Win 8.1 (x32/x64), 2008 Server, 2012 R2 Server, 2016 Server, Win 10 (x32/x64), and 2019 Server.  All servers OSs are installed with GUI and DataCenter version.

    In my environment I use:

    HCK to test Win7, Win8.1, 2008 Server, and 2012 Server.
    HLK 1803 to test 2016 Server
    HLK 1809 for Win 10 and 2019 Server.

    Then i use HLK 1809 to bundle all of the OSs test packages along with my Printer driver and any supplementary forms to create a single package for approval submission.

    I cannot install the HLK 1809 client on 2016 Server since it says it's not compatible so I'm stuck with having to use HLK 1803.

    Does my environment make sense?  It doesn't seem efficient to me so is there a better way to do this?  Does anyone else have this same or similar problem?  Why does Microsoft make things so complicated?

    Sunday, December 30, 2018 8:33 AM