locked
my asp.net page doesn't seem to run simultaneously RRS feed

  • Question

  • User-2085604279 posted

    hello. I'm testing a simple webform with EnableSessionState set to False (and also ReadOnly)

    in the page load, I added these

           Response.Write(Now & "<hr>")

      Threading.Thread.Sleep(5000)

     Response.Write(Now & "<hr>")

    when I try to run this page via two different browser tab, the second one will wait for the first one to finish. How do I ensure that they both runs at the same time ? any help would be greatly appreciated

    Thursday, October 31, 2019 7:44 AM

All replies

  • User475983607 posted

    nickcloudhax

    when I try to run this page via two different browser tab, the second one will wait for the first one to finish. How do I ensure that they both runs at the same time ? any help would be greatly appreciated

    The second request will always complete after the first when accessing the same page.  Use two different pages or add a parameter that sets the Sleep value.

    Thursday, October 31, 2019 10:31 AM
  • User753101303 posted

    Hi,

    Never tried at least since very long. You disabled session state at the page level or entirely? I assume it works if calling the same page from another browser?

    If I remember ASP.NET Core enhanced a bit concurrent access to the session.

    Thursday, October 31, 2019 12:03 PM
  • User288213138 posted

    Hi nickcloudhax,

    when I try to run this page via two different browser tab, the second one will wait for the first one to finish. How do I ensure that they both runs at the same time ?

    According to your description, I couldn’t understand your requirement clearly.

    Do you mean you want to run Web Application in Multiple Browser Simultaneously?

    If this is your requirement, you could refer to below operating, then select the browser you want to use.

    If I misunderstand your requirement, please post more details information about your requirement.

    Best regards,

    Sam

    Friday, November 1, 2019 5:59 AM