WMI does not report all logical disks remotely RRS feed

  • Question

  • I have a workgroup server (Windows Server 2012) that is disconnected from the domain, and I am having an issue getting accurate WMI information from a remote connection.  The account being used is a local account, and a member of the Local Administrators group.  winrm quickconfig shows as already being configured for remote management, and remote management is enabled on the server.

    The machine has a single physical disk, which contains 2 logical partitions.  When logged in directly to the server, the Physical Disk counters show "Disk 0 C: D:" reflecting that there are 2 partitions on that disk, and Logical Disk shows separate instances for C: and D: as it should.  However, when connecting to WMI remotely, Physical Disk still show correctly as "Disk 0 C: D:" but there is only one instance (C:) under Logical Disk, so it is impossible to retrieve performance metrics for D:, such as file activity.

    I am at a loss for how to troubleshoot this issue.  I have tried turning the firewall off completely, with no change, which makes sense since one would expect a firewall restriction would result in an inability to connect remotely alltogether and that is not the case.  I have also tried using the LocalMachine\Administrator account, and it is no different.

    Additional information: UAC is turned off, and the registry already contains the LocalAccountTokenFilterPolicy=1 entry.

    I would appreciate any ideas someone might have to help troubleshoot this discrepancy. Thanks

    • Edited by Tim Batts Monday, June 17, 2013 6:01 PM
    Monday, June 17, 2013 5:59 PM


  • We were able to resolve this by performing a winmgmt /resyncperf followed by a server restart in order to force rebuild everything in WMI.  The counters/instances were all present as evidenced by the fact that everything was visible when on the local server, however WMI was not handling them correctly.

    • Marked as answer by Tim Batts Wednesday, June 19, 2013 4:57 PM
    Wednesday, June 19, 2013 4:57 PM