locked
WCF - Service could not be activated RRS feed

  • Question

  • User1354084251 posted

    I have no idea how to troubleshoot the following error.

    The requested service, 'http://webservices.freemathtest.com/Service.svc' could not be activated. See the server's diagnostic trace logs for more information.

    I don't have access to the server's diagnostic trace logs.  This is a shared hosting account.

    If it helps, you can see the error at http://webservices.freemathtest.com

    Monday, November 10, 2008 8:25 PM

All replies

  • User-914950404 posted
    Hi, Did you solved this problem. if so please let me know the solution. Thanks Dinesh
    Wednesday, April 8, 2009 1:08 AM
  • User1354084251 posted

    No.  I stopped working with WCF because nobody could help

    Wednesday, April 8, 2009 8:27 AM
  • User1899630086 posted

    Sometimes this error could be caused by a tag called 'extendedProtectionPolicy'. Just you need comment or delete this tag and the service finally works.

    Monday, November 22, 2010 2:50 PM
  • User-1712204250 posted

    Which tool/technology are you using to consume the web service.

    If .NET, do you've any kind of the following settings generated in web/app .config file (don't match exact, try to serach'em in config file). Sometimes these kind of additional settings get added. Remove them, Regenerate proxy, & try again.

    This happened to me once. I regenerated  proxy & also removed following from web.config & things started working fine.

    1. <appsettings>

    <add key="Microsoft.VisualStudio.Enterprise.AspNetHelper.ChannelName" value="38fb849c-67f7-4be0-b16d-b4be992f131e" />

    <add key="microsoft.visualstudio.teamsystems.backupinfo" value="22;web.config.backup.280d9f17-6b50-480a-a811-c09580bbca14" />

    Removed these keys.

    2. <compilation targetFramework="4.0" assemblyPostProcessorType="Microsoft.VisualStudio.Enterprise.Common.AspCoverageInstrumenter, Microsoft.VisualStudio.Enterprise.AspNetHelper, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />

    Removed assemblyPostProcessorType

    3. <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="Microsoft.VisualStudio.Enterprise.AspNetHelper" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" />
            <codeBase version="11.0.0.0" href="file:///C:/Program%20Files%20(x86)/Microsoft%20Visual%20Studio%2011.0/Common7/IDE/PrivateAssemblies/Microsoft.VisualStudio.Enterprise.AspNetHelper.DLL" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>

    Removed this runtime/assemblyBinding section.

    Wednesday, February 12, 2014 4:56 AM