none
Debugging settings problem

    Question

  • I've changed some setting somewhere and now...

    if I have Project/Options/Debug option "Enable native code debugging" NOT checked, I can't type at a breakpoint (It's as if VS is just ignoring the keyboard, except the arrow keys)

    if I have the option checked, I can type, but I immediately get the message "Changes are not allowed when unmanaged debugging is enabled.

    

    My Debug menu item option settings are

    and Edit & Continue...

    I've also tried turning on and off the "Native option" here

    Please help - it's driving me crazy!

    Friday, February 24, 2017 11:24 AM

Answers

  • I finally found it. The Framework was set to 4.5 - I changed it to 4.5.1 and all is OK again

    Thanks to Cyrille and Jack-Zhai

    • Marked as answer by iLens Sunday, February 26, 2017 11:46 AM
    Sunday, February 26, 2017 11:46 AM

All replies

  • Are you certain that you are running the project in Debug mode and not Release?

    Just saying...it happened before

    Friday, February 24, 2017 11:49 AM
  • Configuration: Active (debug) is ticked and output path is bin\Debug\ so I'm prettty sure it's running in debug

    BTW it's Framework 4.5

    Friday, February 24, 2017 12:01 PM
  • Hi iLens,

    Which kind of app did you debug? Whether all projects have the same issue?

    (1)E&C has some limitations:

    https://msdn.microsoft.com/en-us/library/7932e88z(v=vs.120).aspx

    Please check it.

    (2) Change the platform target to be the X86 or Any CPU, test it again.

    (3) If still no help, just reset the VS settings, and then just disable/enable the previous options like E&C and Enable native code debugging, how about the result?

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, February 26, 2017 10:13 AM
    Moderator
  • I finally found it. The Framework was set to 4.5 - I changed it to 4.5.1 and all is OK again

    Thanks to Cyrille and Jack-Zhai

    • Marked as answer by iLens Sunday, February 26, 2017 11:46 AM
    Sunday, February 26, 2017 11:46 AM