none
Access denied for full controll users at feauture activation RRS feed

  • Question

  • When a full control user (also farm admins) tries to activate this feature:

    Hide the View All Site Content link

    Removes (hides) the View All Site Content from the quick link navigation and adds a View All Site Content link to the Site Action menu. The new Site Action link is only visible to users having the AddAndCustomizePages right.

    He will get a active denied and wont be able to activate the feature. If i look at the log file all i can find is this:

    05/27/2010 10:58:45.06  w3wp.exe (0x01AC)                        0x05D4                                1463                           8l41 High     assertPermissionMask was called, but permissions haven't been computed yet.

    The activation of this feature has always worked, but stopped suddenly. Activating another feature is no problem. As far as i know there is nothing changed in our farm or updated.

    Does anyone has a idea what this can be or how we can get more detailed logs.

    Thanx

    • Moved by Mike Walsh FIN Thursday, May 27, 2010 9:48 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, May 27, 2010 9:21 AM

All replies

  • Problem is still existing, but i found some more logs on our web front end server.

    06/01/2010 12:06:33.17  w3wp.exe (0x1464)                        0x206C Windows SharePoint Services    General                        75fb Medium   Calling 'FeatureActivated' method of SPFeatureReceiver for Feature 'VASCSiteAction' (ID: 'fc5e2840-0b48-42eb-9ad7-076f5add58ad'). 
    06/01/2010 12:06:33.17  w3wp.exe (0x1464)                        0x206C Windows SharePoint Services    General                        8e2s Medium   Unknown SPRequest error occurred. More information: 0x80070005 
    06/01/2010 12:06:33.20  w3wp.exe (0x0378)                        0x1ED8 SharePoint Portal Server       Runtime                        8gp7 Medium   Topology cache updated. (AppDomain: /LM/W3SVC/1968038899/Root-1-129198493195312467) 
    06/01/2010 12:06:34.45  w3wp.exe (0x2528)                        0x1558 SharePoint Portal Server       Runtime                        8gp7 Medium   Topology cache updated. (AppDomain: /LM/W3SVC/1868333483/Root-1-129198464909900879) 
    06/01/2010 12:06:35.84  w3wp.exe (0x1464)                        0x206C Windows SharePoint Services    General                        88jb Medium   Feature Activation: Activating Feature 'VASCSiteAction' (ID: 'fc5e2840-0b48-42eb-9ad7-076f5add58ad') at URL http://site_adres_i_try_to_activate_the_feautur_on
    06/01/2010 12:06:35.86  w3wp.exe (0x1464)                        0x206C Windows SharePoint Services    General                        72ix Medium   Not enough information to determine a list for module "VASCSiteAction". Assuming no list for this module. 
    06/01/2010 12:06:35.86  w3wp.exe (0x1464)                        0x206C Windows SharePoint Services    General                        8e27 Medium   Ensuring module folder _styles 

    Tuesday, June 1, 2010 10:25 AM
  • Hi Nukkel,

    Try to check again permission of user who is activating this feature. And what message its showing after activating feature? Is it showing Access Denied error/page?

    and can you show your 'FeatureActivated' method? so it would be easy to debug your code and problem.

     

    Regards,

     


    N i T i N
    Tuesday, June 1, 2010 10:45 AM
  • Hi,

    Yes it shows the Access Denied error/page after i click on activate. The permission of the users who get this is full control. All site owners with full control have this problem on there page. They can do everything else what needs full control normally. Also the site admins can't activate this feature.

    This is the feature whe are using:

    http://vasc.codeplex.com/

    But the last version of this feature is from januari and nobody else is complaining about it on the site and it has worked for us in the past i think the problem has something to do with our own SharePoint environment and not with this webpart.

    Tuesday, June 1, 2010 11:49 AM