locked
VS2k5 .Net - Recompling previous versions Problem RRS feed

  • Question

  • Hi all,

    I wrote a program in VS2k3 .Net a couple of years ago, and recently I wrote a program in VS2k5 using the ver. v2.0.50727. of .Net. The thing is when install the program complied in VS2k5 .Net on a computer that is running the program complied in VS2k3 .Net, I receive an error: Different version of .Net required. So I install the newest version of .Net, but then the program compied in VS2k3 .Net doesn't want to work???

    So my question is, everytime Microsoft releases a new .Net framework, does the whole program have to be re-complied / re-written ???

    Thank you

    Regards

    Programm3r

    Thursday, November 9, 2006 5:23 AM

Answers

  • Program written in VS2003 can run under .NET Framework 1.1 or later. Install .NEt Framework 2.0, both programs can run under it. .NET Framework versions are backward compatible.
    Thursday, November 9, 2006 7:26 AM

All replies

  • Program written in VS2003 can run under .NET Framework 1.1 or later. Install .NEt Framework 2.0, both programs can run under it. .NET Framework versions are backward compatible.
    Thursday, November 9, 2006 7:26 AM
  • Thank you Alex...
    Thursday, November 9, 2006 12:27 PM