How to "ALLOW" GEO location on device in a UITest when dlg doesnt appear on REPL RRS feed

  • Question

  • User116733 posted


    With update to marshmallow, access to geolocation is now requested on demand, this displays an dlg with a DENY or ALLOW button (see attached screen shot), this doesnt seem to appear in REPL, what is best way to dismis this dialog with ALLOW or DENY to test both scenarios.


    Neil Pepper

    Friday, April 22, 2016 2:24 PM

All replies

  • User139314 posted

    @Neil_Pepper Make sure you are using the latest stable version of Xamarin.UITest. When the app is installed on an Android M or greater device it is granted "all" permissions so permission dialogs should not appear.

    Note that running locally you will need to ensure that UITest does the install for Android M (instead of the IDE). See: https://forums.xamarin.com/discussion/comment/183966/#Comment_183966

    Also, SetLocation in UITest now works on Android M devices starting with Xamarin.UITest 1.3.8: http://forums.xamarin.com/discussion/62446/xamarin-uitest-1-3-8

    Thursday, May 5, 2016 10:22 PM
  • User116733 posted

    Thanks @Glenn.Wilson , yes managed avoid message in the end when installing app via code so it has all the permissions granted on install. Spotted an adb install option to do this and worked out thats what xamarin must do too.


    Friday, May 6, 2016 3:56 PM
  • User57571 posted

    @Glenn.Wilson What about iOS? Should we use AppBundle(Path)?

    Monday, January 30, 2017 7:04 PM
  • User139314 posted

    @15mgm15 The issue discussed previously in this thread is for an Android only issue. If you have a different question please start a new thread.

    Monday, January 30, 2017 8:09 PM
  • User57571 posted

    AppBundle(Path) Did the trick, Thanks anyways!

    Monday, January 30, 2017 8:40 PM