locked
Problems with FrontPage Server Extensions, IIS6, Multiple Sites using Host Headers and Visual Studio 2005 RRS feed

  • Question

  • User175429127 posted

    Hi,

    I really hope someone can help me, I've been going round in cricles with this problem!

    Scenario:

    I have a virtual server Windows 2003 Server with IIS6. FrontPage Server Extensions 2002 are installed. I want to use Host Headers to have multiple websites running. I have configured this and I can access the sites through the browser using the site name eg: http://TestSite 

    However, I cannot open the websites remotely anymore with Visual Studio 2005.

    The error I get is that FPSE are not installed. I have tried to configure FPSE, but it seems to hang, at one stage I left work on Friday with it running and when I came in on Monday it was still running!

    When I go into Microsoft Sharepoint Administrator it appears as though the Extensions have been configured, but they appear to have different versions!

     See below:
      Default Web Site  http://Server  5.0.2.6738  Administration  
        TestFrontPage  http://FP  5.0.2.6790  Administration 

    If I try to open the site in Visual Studio it doesn't work with the error that FPSE is not installed.

    I have tried to manually create a virtual directory called _vti_bin below the testFrontPage site pointing it to the C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\50\isapi and still it doesn't work.

    Can someone please help me?

     

    Wednesday, December 10, 2008 5:00 AM

All replies

  • User175429127 posted

    Sods law, I guess but the minute you post something and admit your ignorance you sort it out. Well, almost anyway.

    I have the debugging working through moving the website folder out of the wwwroot folder. May seem obvious now, but I didn't think of it at the time.

    But, my FPSE problems persist in a way. The different version numbers still appear and the web page that says please wait while your changes are processed never changes. If I just cancel out of the window, the site works and it appears as though FPSE is installed.

    Wednesday, December 10, 2008 7:33 AM