none
Segment level error in EDI852 file RRS feed

  • Question

  • Hi got follwing error when im processing EDI 852 files,

    please any one help me , im new to EDI

    Any quick reponse is appreciated.

    Details: Error: 1 (Segment level error)
    SegmentID: XQ
    Position in TS: 0
    3: Mandatory Segment Missing

    Error: 2 (Segment level error)
    SegmentID: N1
    Position in TS: 0
    2: Unexpected segment  

    Thanks ,

    Rao

    Wednesday, February 20, 2013 4:33 AM

Answers

All replies

  • Hi got follwing error when im processing EDI 852 files,

    please any one help me , im new to EDI

    Any quick reponse is appreciated.

    Details: Error: 1 (Segment level error)
    SegmentID: XQ
    Position in TS: 0
    3: Mandatory Segment Missing

    Error: 2 (Segment level error)
    SegmentID: N1
    Position in TS: 0
    2: Unexpected segment  

    Thanks ,

    Rao

    Wednesday, February 20, 2013 4:33 AM
  • as Error shows

    XQ segment is missing which is mandatory.

    you can disable EDI Validation in EDI Pipeline settings.

    Regards

    Mohit

    Wednesday, February 20, 2013 10:49 AM
  • thanks for reply guptha,

    already i disable the validation , got follwing error,

    i using edi send pipie line ,

    please let me know where im to dig ?

    Details:"Unable to read the stream produced by the pipeline. 
     Details: Error: 1 (Segment level error)
    SegmentID: XQ
    Position in TS: 0
    3: Mandatory Segment Missing

    Error: 2 (Segment level error)
    SegmentID: N1
    Position in TS: 0
    2: Unexpected segment ".

     it is EDI X12_00401_852.xsd


     
    Wednesday, February 20, 2013 11:19 AM
  • have you configure send party , after configure send party .you can enable EDI Validation


    Regards

    Mohit

    Wednesday, February 20, 2013 11:33 AM
  • thanks fro quick reply,

    where im  find  to these properties page ,

    please ..



    • Edited by anilrao Wednesday, February 20, 2013 11:40 AM
    Wednesday, February 20, 2013 11:39 AM
  • create aggrement for parties and then will get these interchange settings

    Regards

    Mohit

    Wednesday, February 20, 2013 11:40 AM
  • Refer Article

    Regards

    Mohit

    Wednesday, February 20, 2013 11:42 AM
  • im really thankful  to you,

    im send the xm to edi852, i hope parties looking fine,

    here im using edi send pipeline,  im not sure problem is here, but when try with passthru it seems to be working fine

    if you want any more details ,,pleasee

    Wednesday, February 20, 2013 12:07 PM
  • EDI Pipeline perform EDI Validation.

    Passthrough will not generate in EDI Format.

    Details:"Unable to read the stream produced by the pipeline. 
     Details: Error: 1 (Segment level error)
    SegmentID: XQ
    Position in TS: 0
    3: Mandatory Segment Missing

    Error: 2 (Segment level error)
    SegmentID: N1
    Position in TS: 0
    2: Unexpected segment ".

    if XQ is mandatory as per your spec then put value else change to optional

    set N1 value to O1 or as per  your req

    Regards

    Mohit

    Wednesday, February 20, 2013 12:49 PM
  • Hi guptha, 

    as per ur suugestion , it seems to be didnot chage , i got same error

    pleasee let mek know ?

    Wednesday, February 20, 2013 12:59 PM
  • Hi Anil

    put 01 in N1 Value , and is XQ mandatory as per partner Specification

    Regards

    Mohit

    Wednesday, February 20, 2013 1:32 PM