locked
Package.AppxManifest problem when switching between target buildd

    Question

  • Hi,

    My Windows Store package manifest declares the application like this :
    <Application Id="MyApp.App" Executable="$targetnametoken$.exe" EntryPoint="MyApp.App">

    I have several target builds (debug & release) each one outputs a .exe with a specific name, respectively MyApp_Debug.exe & MyApp_Release.exe.
    If I build & run the debug target, everything work well. But, then if I switch to the release target and build & run it, I got an error :
    "Package.AppxManifest : error APPX0703: Manifest references file 'MyApp_Debug.exe' which is not part of the playload."

    It seems that Visual still looking for the .exe file related to the previous build of the debug target.
    If I edit the Package.AppxManifest as XML with any fake modification (like adding any space or line return somewhere), just to force it saved again, the error is finally solved and the release build works as well.
    Of course, If I go back to debug: same issue, it's seraching the release .exe instead of the debug one until I put a modification in the manifest.

    It looks like there is a kinf of cache not refreshed.

    Any idea to workaround thi Visual bug more conveniently ?

    Thanks.

    Thursday, April 25, 2013 3:23 PM

All replies

  • Hi,

    I'll try to involve more experts in this case.


    Aaron
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, April 26, 2013 10:12 AM
  • I have a similar problem, except that I have two different projects in the same solution.  If I build clean, and then build it works fine.  If the project names were Project1 and Project2, then the second time I build the solution Visual Studio will say:

    Package.appxmanifest : error APPX0703: Manifest references file 'Project1.exe' which is not part of the payload

    when it builds Project2.  That is, it seems to be looking for the Project1 executable when it is building Project2.

    Thanks,
    Bill.

    Tuesday, May 21, 2013 6:13 PM
  • I have a few questions:

    1) What language are you using (C#, C++, etc)

    2) Are you using the default Debug/Release configurations or do you have custom ones?

    3) Do you get these errors when just building or do you have to deploy to get them?

    4) Do you still get them if you do a rebuild?

    5) Are you using the Dev12 Preview build or Dev11 RTM?

    Thanks,

    Luke

    Wednesday, July 17, 2013 10:07 PM