none
A very weird Install problem RRS feed

  • Question

  • Hi everyone, 

    I don't know which forum to post this question. Since it has something to do with a Setup, I resort to here. (Although it's about installing my own program)

    I wrote a Windows Service, and a Setup project to install that Windows service in Visual Studio 2010. 

    However, after I run the Setup to install the service on a Windows machine, I tried to start the service but the service failed to start. 

    I then added some try/catch, and found that the service failed because it could not load a class from one of my assembly. 

    By a further look into the installed directory, i found that the particular dll causing problem is a 2-months-ago version (i've done installation 2 months ago) , which is so weird that all other dlls are replaced with newer version by the installation except this one!

    I then manually deleted that dll and re-run the Setup, everything works fine. 

     

    This is SO WEIRD!

    Do you guys have any clue of why it happened?

     

    thanks a lot!

    Thursday, December 16, 2010 9:42 AM

Answers