none
Broker:Connection_Connection handshake failed. An OS call failed: (8009030c) 0x8009030c(The logon attempt failed). State 67__ RRS feed

  • Question

  • I am trying to send a message between 2 different instances in the same domain.I am getting the above error.The SQl Server  is logged on as NTService\MSSQlSERVER in both the instance.I am not able to create any login with domain\machine$ .What should be the user to be created and grant permission on the end points in order to avoid this error.Can we create any  login with sql server authentication and try to send message with this user.
    Monday, November 19, 2018 9:41 AM

All replies

  • You cannot use SQL authentication with Service Broker.

    I assume that the two instances are running on different machines? Keep in mind that although the name is the same, they are two different NTService\MSSQLSERVER, as they are local to the machines.

    What do you mean with "I am not able to create any login with domain\machine$"? Do you get an error message when you try? In such case, can you disclose it?

    The alternative to use Windows authentication is to use certificates.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Monday, November 19, 2018 12:10 PM
  • Thanks Erland For your reply.

    Yes the instance are on different machine and it run on the same domain.

    I am getting below error while i try to create login

    Windows NT user or group 'Domain\machinename$' not found. Check the name again.

    Which user has to be given grant conncetion permission on the endpoint?

    Monday, November 19, 2018 1:22 PM
  • You should check with your Windows admin why you cannot create a login for the machine name. If that does not work out there are two options:

    1. Change the service account(s) to be domain accounts.
    2. Use certificate authentication.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Monday, November 19, 2018 2:49 PM
  • Sure.I will do the same.

    Thanks for your valuable Feedback

    Tuesday, November 20, 2018 1:36 AM