locked
cannot install Visual Studio 2008, Error code 1603 RRS feed

  • Question

  • User1850575723 posted

    Hi All, I was installing vs2008 Team System edition, and I cancelled the instalation process (bad idea), now when I try to install vs2008 again, instaltion process fails sending this error:

    [04/06/08,17:06:02] Microsoft .NET Framework 3.5: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [04/06/08,17:06:02] Microsoft .NET Framework 3.5: [2] Setup Failed on component Microsoft .NET Framework 3.5
    [04/06/08,17:06:04] VS70pgui: [2] DepCheck indicates Microsoft .NET Framework 3.5 is not installed.
    [04/06/08,17:06:04] VS70pgui: [2] DepCheck indicates Microsoft Document Explorer 2008 was not attempted to be installed.
    [04/06/08,17:06:04] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Web Authoring Component was not attempted to be installed.
    [04/06/08,17:06:04] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Team System 2008 Development Edition - ENU was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft .NET Compact Framework 2.0 SP2 was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft .NET Compact Framework 3.5 was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Tools for the Microsoft Office system (version 3.0 Runtime) was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2005 Tools for the 2007 Microsoft Office System Runtime was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 Design Tools was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 For Devices was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Windows Mobile 5.0 SDK R2 for Pocket PC was not attempted to be installed.
    [04/06/08,17:06:05] VS70pgui: [2] DepCheck indicates Windows Mobile 5.0 SDK R2 for Smartphone was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Microsoft Device Emulator version 3.0 was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 Tools (x86) was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 .NET Framework Tools (x86) was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 SDK Reference Assemblies and IntelliSense (x86) was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2008 Performance Collection Tools (x86) was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Crystal Reports Basic for Visual Studio 2008 was not attempted to be installed.
    [04/06/08,17:06:06] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard was not attempted to be installed.

    My sandbox is:

    -Windows xp professional sp2
    -Visual Studio 2003 installed
    -Visual Studio 2005 installed

    I already tried to install .NET Framework 3.5 separately, and this erros is raised.
    [04/06/08,17:13:44] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
    [04/06/08,17:14:02] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
    [04/06/08,17:40:28] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
    [04/06/08,17:40:50] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
     
    Please help.
    Thanks
    Horacio

     

    Sunday, April 6, 2008 5:58 PM

All replies

  • User-1363174918 posted

    Perhaps this post will help with diagnostics: http://blogs.msdn.com/astebner/archive/2005/08/01/446328.aspx

    Monday, April 7, 2008 1:56 AM
  • User1850575723 posted

    Thanks for your help, I solved my problem following these steps:

    1 goto %temp% folder

    2 open dd_NET_Framework30_Setup449F.txt

    3 look for string "return value 3"

    next lines show the error, on my case I nedded permissions to this key on regestry.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0

    Regards,

    Horacio

    Sunday, April 13, 2008 1:42 AM
  • User1002305701 posted

    hello Mr Horacio,

    how to look the problem in your case which needed permission on key regestry

    And then how we fix this problem

     

    Regard,

     Andi

    Tuesday, October 14, 2008 4:50 AM
  • User335083564 posted

    I had the same annoying problem also. I was this close to formatting my computer cause I had a really urgent project to work on. I ran PC-Kitchen's RegistryCleaner (it doesn't matter which Registry Cleaner you run) and it solved the problem.

     Apparently the underlying cause is a corrupt registry setting of some sort......... Go figure!

    Thursday, November 6, 2008 11:01 AM
  • User1850575723 posted

    Hi,

    Go to regedit tool and find this key

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0

    Right click on that key and to to permissions, then grant full control to ASP.NET local machine user account.

    Regards

    Horacio 

     

    Thursday, November 6, 2008 11:13 AM
  • User-603505870 posted

    Thanks Randy!

    Excellent post, RegistryCleaner solved this issue.......

    Wednesday, November 12, 2008 7:00 AM
  • User-1672130933 posted

    I was having similar issues. I tried several of the sugestions here and on other forums and had no success. I then got the dotnetfx35.exe that includes service pack 1 (the size of the file should be 237,054 kb) and installed it. An office mate of mine had told me that they had fixed some of the install issues with this update. It installed fine and I was then able to install VS 2008 with no further issues.

    Friday, November 28, 2008 2:14 PM
  • User-982078866 posted

    I was having similar issues.  Tnx to Randys post i solved it.

    I used the: RegistryCleaner he recomand and it solve my problems and some other Registry issue i had

    tnx randy u just saved me from formating my computer.
    Friday, December 5, 2008 1:22 PM