locked
Can you manage your SSRS in VS 2012 for a 2008 R2 Reporting Server? RRS feed

  • Question

  • User1462999811 posted

    I need to know if you can upgrade your reporting services reports to Visual Studio 2012 and publish them to the reports server that is running 2008 R2? Anyone know if this is doable or should I keep my reports mangaged in VS 2008?

    Wednesday, March 5, 2014 1:01 PM

Answers

  • User1140095199 posted

    Hi,

    atariman5000

    I need to know if you can upgrade your reporting services reports to Visual Studio 2012 and publish them to the reports server that is running 2008 R2? Anyone know if this is doable or should I keep my reports mangaged in VS 2008?

    I guess you want to upgrade SSRS Reports from 2008 R2 to 2012. Yes it definitely doable.

    When you upgrade a Reporting Services installation to a SQL Server 2012 Reporting Services (SSRS) installation, existing reports and snapshots that have been published to a report server are compiled and automatically upgraded to the new schema the first time they are processed. If a report cannot be automatically upgraded, the report is processed using the backward-compatibility mode. The report definition remains in the original schema.

    Source Article:

    Upgrade Reports - http://msdn.microsoft.com/en-us/library/ms143674.aspx

    If you experience errors or issues when you try to upgrade Reporting Services, use the instructions in this topic to address the conditions that are most likely to cause upgrade issues.

    For The latest information regarding issues with SQL Server 2012, see Reporting Services SQL Server 2012 Tips Tricks, and Troubleshooting

    For more troubleshooting issues - http://msdn.microsoft.com/en-us/library/hh759330.aspx

    Now, One last thing I don't see any reason of upgrading the Reports to 2013 and running them in Report Server 2008. Better get it completely upgraded or NOT do it at all.

    "Can you manage your SSRS in VS 2012 for a 2008 R2 Reporting Server"

    Yes, we can do it. It is backward compatible.

    If I am missing a point here do write back with more details.

    Best Regards!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 6, 2014 1:16 AM