none
Upgraded to VS2015, get error when opening projects in older versions

    Question

  • Went from VS2013 Premium to VS2015 Enterprise. I cannot open projects from earlier versions without getting the following error message:

    The data provided was not valid XML. See log for more details.

    I need this error to go away. It is actually preventing us from running our overnight ATPs in 2010 projects since the build tool actually opens up the project and this error message is blocking. If I click "OK" on the error message, everything builds and runs fine. I really need this to go away. Any help is appreciated.


    • Edited by Randae Tuesday, November 22, 2016 6:44 PM
    Tuesday, November 22, 2016 6:34 PM

Answers

  • Hi Randae,

    According to your description, after installing Visual Studio 2015, other version of Visual Studio could not open corresponding project, is it right?

    First, please right-click the .sln file that you want to open and choose the corresponding version of Visual Studio. Make sure you are choose the correct version of Visual Studio. When there are several version of Visual Studio installed on the same machine, if you double-click the .sln file, it will be opened by the Visual Studio you set as default program for .sln file.

    If you have choose the correct version of Visual Studio, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Randae Friday, December 02, 2016 2:11 PM
    Tuesday, November 29, 2016 2:06 AM
    Moderator

All replies

  • Hi Randae,

    As far as I know, the higher version Visual Studio project is incompatible with low version Visual Studio. Because the higher version project often use the higher version assembly, which is not supported in low version Visual Studio.

    If your project is not used the higher version Visual Studio features, you could try modify the project file to let it could be opened in low version of Visual Studio.

    Please refer to:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/54fc2f68-551a-42c9-ae1f-4b88cadab256/how-do-you-open-visual-studio-2015-projects-in-visual-studio-2010?forum=visualstudiogeneral

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 25, 2016 10:06 AM
    Moderator
  • Thank you for the response, but I'm experiencing a problem in the reverse of what you stated. I have higher version visual studio and lower version of project.

    Furthermore, upon installing visual studio 2015, I am getting the error messages when opening a 2010 project with visual studio 2010, and if I open a 2013 project with visual studio 2013. I have many versions of visual studio installed on my machine since we still get bug reports on some of our products no longer being developed. This is seriously impacting or testing.

     
    Monday, November 28, 2016 2:48 PM
  • Hi Randae,

    According to your description, after installing Visual Studio 2015, other version of Visual Studio could not open corresponding project, is it right?

    First, please right-click the .sln file that you want to open and choose the corresponding version of Visual Studio. Make sure you are choose the correct version of Visual Studio. When there are several version of Visual Studio installed on the same machine, if you double-click the .sln file, it will be opened by the Visual Studio you set as default program for .sln file.

    If you have choose the correct version of Visual Studio, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Randae Friday, December 02, 2016 2:11 PM
    Tuesday, November 29, 2016 2:06 AM
    Moderator
  • I checked the activity log when the error message was onscreen and at the bottom it clearly showed the problem. It was a plugin that was causing the problem. I uninstalled the plugin and things work fine now. Thanks.
    Friday, December 02, 2016 2:11 PM