locked
Workspace with wrong username RRS feed

  • Question

  • Is there somewhere that the username Team Foundation Client used to connect to TFS is cached?

    My problem is that TFC is connecting to TFS using my admin account, even though I'm logged in with my regular account.

    I'm wondering if it has cached the admin account somewhere, as when I first setup up TFS and TFC, I think it prompted me for a username/password as I hadn't given my regular account permission in TFS.

    So now it keeps creating a new workspace called "BANANAS;adminacct" instead of using the existing workspace "BANANAS;regularacct".

    This was all working fine last week, and I don't understand what has changed to cause this problem.

    It seems to me that if I can get TFC to forget about my admin account, then it might all work properly again. I tried uninstall/reinstalling TFC, but that didn't help.

    (I'm using TFS Beta 3)

    -dave
    Monday, February 13, 2006 2:35 AM

Answers

  • If you did use the login dialog at some point and you checked the "Remember my password" box, it will always use the credentials that were saved until they failed, perhaps due to the password changing.  Because of that created problems like this, we removed that checkbox for RC and RTM.

    Unfortunately, the credentials don't show up in the Windows Stored User Names and Passwords control panel applet.  So, the easiest way out could be to change the admin password so that authentication fails.  Of course, changing passwords may have other ramifications, so it's possible that your solution was less work in your case.

    Buck

    Tuesday, February 21, 2006 7:26 PM
    Moderator

All replies

  • David,

    The client keeps a cache that maps local working directories to servers and workspace names.  IIRC, the username is stored as part of the workspace name.  If you rebuild that cache, it should only let you see BANANAS;regularacct. 

    Try running the following command from the VS 2005 command prompt.

    tf workspaces /s:tfsservername

    If you are prevented from creating BANANAS;regularacct due to a working folder conflict, have the administrator delete the adminacct workspace.

    Thanks,

    Justin Pinnix

    SDE - Version Control Server

     

    Thursday, February 16, 2006 7:42 PM
  • Hi Justin,
        thanks for the reply.

    I did try deleting the adminacct workspace (which worked in itself).

    However, when I then re-connected to TFS using the client, the adminacct workspace was re-created.

    I did a search of my registry and file system but couldn't find anything (in clear text anyway) related to this, so I can only assume that the adminacct credentials had been cached away somewhere secret (protected storage maybe).

    The downside of this is that I'm not aware of a way to make the computer forget this.

    I ended up blowing away my Windows login profile which has solved that problem (though of course i now need to reconfigure the settings in all the applications on my machine :-( )

    -dave


    Thursday, February 16, 2006 11:35 PM
  • If you did use the login dialog at some point and you checked the "Remember my password" box, it will always use the credentials that were saved until they failed, perhaps due to the password changing.  Because of that created problems like this, we removed that checkbox for RC and RTM.

    Unfortunately, the credentials don't show up in the Windows Stored User Names and Passwords control panel applet.  So, the easiest way out could be to change the admin password so that authentication fails.  Of course, changing passwords may have other ramifications, so it's possible that your solution was less work in your case.

    Buck

    Tuesday, February 21, 2006 7:26 PM
    Moderator
  • Hi Buck,
        of course - I wish I'd thought of that at the time!

    Having said that, generating a new profile does have its benefits (cleans out a lot of stuff that I probably didn't need!)

    thanks,
    -dave
    Tuesday, February 21, 2006 9:33 PM