none
Can't install .net framework version 4.0 RRS feed

  • Question

  • EVEMon, an application I use veray often, asked me to install .net framework 4.0

    While Running the installation of .net framework 4.0 the following error occured:

    "Unable to execute the embedded appilication to complete the installation"

    I tried every bugfix that's recommended here, but i still cant install .net framework 4.0

     

    I also noticed that the files were extracted to Drive "H:\" while "C:\" is the Drive of the OS.

    Edit: I looked for logfiles in %temp% but there is no logfile.

     

     

    Uninstall .net framework isn't possible, because .net framework doesent show up

    Fix the installation with "Windows Install Cleanup" didn't solve the Problem, but i uninstalled two "parts" of .net framework 4.0 that way... however problem not solved

     

    reinstall the former versions of net. framework doesen't make any difference.

     

    Edit: I also uninstalled a update for .net framework 4.0 but a reinstall of this Update failed too.

    The Errorcode is: WindowsUpdate_0000066A

     

    Any Ideas

     

    (PS: Sorry about my english, i'm swiss)

    • Edited by VEX-Garfield Monday, February 14, 2011 10:02 AM Additional Information
    Monday, February 14, 2011 9:54 AM

Answers

  • I think I had done the following:
    - Download dotNetFx40_Full_x86_x64.exe from http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7
    - Launch commandline prompt as administrator
    - cd (change directory) commandline to location of downloaded dotNetFx40_Full_x86_x64.exe
    - Ran the command: dotNetFx40_Full_x86_x64.exe /x
    - Specified a location to extract when prompted
    - cd commandline to location of extracted files
    - Ran the command: RGB9Rast_x86.msi
    - Ran the command: netfx_Core_x86.msi EXTUI=1
    - Ran the command: netfx_Extended_x86.msi EXTUI=1

    The part I am unsure of is the EXTUI=1 syntax, but I think the above is correct. That's it.

    Friday, March 25, 2011 1:43 PM

All replies

  • I could send u the "vslogs.cab" File if you can tell me how i can upload it.
    Monday, February 14, 2011 10:19 AM
  • I too am having installation issues but not exactly the same...

    Trying to install .NET Framework 4 client sidea nd keep getting an annoying message about Drive A: being open....

    Drive A: is a floppy hich I don't even have installed...

    After attempting to install thru Windows UpDate several time and getting rid of that message after the 3rd attempt I then D/Led the installer and tried that...

    All that happens is the Install starts but nvr get far and that message starts up again...

     

    I'm running WIN XP Pro x64...

     

    I'm no computer guru by any stretch and only wish to update to support another program I wish to use that now requires it...

    Monday, February 14, 2011 3:47 PM
  • Here the logfile if the installation:

    [2/14/2011, 11:26:30] === Logging started: 2011/02/14 11:26:30 ===

    [2/14/2011, 11:26:30] Executable: D:\Downloads\dotNetFx40_Full_x86_x64.exe v4.0.30319.1

    [2/14/2011, 11:26:30] --- logging level: standard ---

    [2/14/2011, 11:26:30] Successfully bound to the ClusApi.dll

    [2/14/2011, 11:26:30] Error 0x80070424: Failed to open the current cluster

    [2/14/2011, 11:26:30] Cluster drive map: '' [2/14/2011, 11:26:30] Considering drive: 'C:\'...

    [2/14/2011, 11:26:30] Considering drive: 'D:\'...

    [2/14/2011, 11:26:30] Considering drive: 'E:\'...

    [2/14/2011, 11:26:30] Drive 'E:\' is rejected because of the unknown or unsuitable drive type

    [2/14/2011, 11:26:30] Considering drive: 'F:\'...

    [2/14/2011, 11:26:30] Drive 'F:\' is rejected because of the unknown or unsuitable drive type

    [2/14/2011, 11:26:30] Considering drive: 'H:\'...

    [2/14/2011, 11:26:30] Drive 'H:\' has been selected as the largest fixed drive

    [2/14/2011, 11:26:30] Directory 'H:\d0e9c90e298ad38815\' has been selected for file extraction

    [2/14/2011, 11:26:30] Extracting files to: H:\d0e9c90e298ad38815\ [2/14/2011, 11:26:37] Extraction took 7.254 seconds

    [2/14/2011, 11:26:37] Executing command line: 'H:\d0e9c90e298ad38815\\Setup.exe /x86 /x64'

    [2/14/2011, 11:26:37] Error 0x80070667: Failed to start the process

    [2/14/2011, 11:26:37] Error 0x80070667: Failed to execute file [2/14/2011, 11:26:40] Exiting with result code: 0x80070667

    [2/14/2011, 11:26:40] === Logging stopped: 2011/02/14 11:26:40 ===

    • Edited by VEX-Garfield Tuesday, February 15, 2011 11:12 AM make it readable
    Tuesday, February 15, 2011 12:51 AM
  • I still need help!!!

    I tried to backup the system from a former date, but that is not possible. The systembackup-application (Standard-Program) says it's been blocked by something.

    Even a deinstallation of the Viral-Protection, like recommended, did not work.

     

    I also tried the RegistryBooster from Uniblue which i purchased just for this issue, but besides repair 230 Issues, it didn't solve this particular problem at all.

     

    I'm not able to install or uninstall or reinstall .net Framework 4.0

    I'm no longer able to reinstall the Update for .net framewor 4.0 which was installed before. (I guess .net framework 4.0 is/was installed but it doesn't work)

    A system Back up is not possible.

     

     

    I guess these 3 Problems are come from the same cause.

    I tried to install .net framework after all these steps, and collected the logfile every time, but it says always the same (like that above).

     

    Additional Information to my System:

     

    - i7 3,2 GHz 6Core CPU.

    - AMD 5870 GPU

    -12 GB RAM DDR3 (by Corsair)

    - Asrock X58 Mainboard

    - Win 7 64bit Ultimate

    - Office Home and Student

     

    Please Help

    Wednesday, February 16, 2011 8:52 AM
  • Hi VEX-Garfield,

    Thank you for posting.

     

    Some questions need to clarify with you.

    Have you installed anti-virus software or any add-ins on your machine?

     

    Generally, 0x80070667 this issue may be attributable to anti-virus. I suggest you can install .Net Framework 4 on the Safe Mode.

     

    If you have any findings, please feel free to let me know.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, February 16, 2011 11:45 AM
  • Hi Larcolais

    Thanks for the hint. Unfortunately it did not work.

    I got AVG installed, but even when i unistalled it and tried again, it didn't work :-(

    I'm not using any special Programms. Mostly games.

    The only PC-Support-Programs i use are:

    - Registry Booster from Uniblue

    - Driver Genius

    - Sweepi


    All other Programms are not supposed to have a serious impact on the Registry.


    Best Regards


    VEX-Garfield
    Thursday, February 17, 2011 8:08 AM
  • Hi VEX-Garfield,

    Have your issue been resolved?

    Did you download the setup from Microsoft website? You can get the Microsoft .NET Framework 4 (Standalone Installer) from the link below: http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7

    NOTE: Please run the setup with Administrator privilege: right click the installer -> Run as administrator.

    Also, would you please send the vslogs.cab file to me (v-anwu@microsoft.com) for further advice? Please attach the link of this post in your e-mail.

    Waiting for your e-mail.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, February 23, 2011 11:59 AM
    Moderator
  • Hi VEX-Garfield,

    Thanks for sending me the e-mail.

    I find the messages below in the log files you sent me:

    [2/14/2011, 11:28:55]KB2473228 does not apply to this computer.
    [2/14/2011, 11:28:56]Final Result: Installation failed with error code: (0x0000066A),

    Would you please download and install the KB2473228 from the link below?
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=ABC8AB0A-3337-4AD7-AE35-ADD9FB10ACF7&displaylang=en

    For more information about this update, please see: http://support.microsoft.com/kb/2473228

    I hope this helps.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, March 9, 2011 3:30 AM
    Moderator
  • If i try to install that KB2473228 the following notification shows up:

    "KB2473228 trifft nicht zu oder wird von einer anderen Bedingung auf Ihrem System blockiert"

     

    Translated to English:

    "KB2473228 does not apply or is blocked by an other condition on your system."

    Would reinstall Win7 help to solve the Problem?

     

    The install logfile shows:

    0x80070642

    Sunday, March 13, 2011 11:49 AM
  • To MSFT -
    I am seeing all the above issues on a brand new laptop from Dell. I cannot insall .NET 4 framework and the above installer from the KB returns the same error for me. What do you need to help figure out why .NET 4 will not install and/or the above KB cannot be applied?

    Could this have anything to do with me using only a solid state harddrive?

    I was able to workaround this issue by extracting the files and following the manual installation instructions posted here:
    http://www.appdeploy.com/packages/detail_pf.asp?id=1814

    Not ideal, but the VS 2010 installer is now continuing.

    Sincerely,
    Scott Richardson

    Wednesday, March 16, 2011 7:19 PM
  • I'll try this....

    gotta look if it works...

    have a SSD too.

    Sincerely

    Simon

     

     

    Edit:

    I'm not a Pro-User and i have some serious problems with the commandline... I don't know the right syntax.

    Friday, March 25, 2011 11:47 AM
  • I think I had done the following:
    - Download dotNetFx40_Full_x86_x64.exe from http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7
    - Launch commandline prompt as administrator
    - cd (change directory) commandline to location of downloaded dotNetFx40_Full_x86_x64.exe
    - Ran the command: dotNetFx40_Full_x86_x64.exe /x
    - Specified a location to extract when prompted
    - cd commandline to location of extracted files
    - Ran the command: RGB9Rast_x86.msi
    - Ran the command: netfx_Core_x86.msi EXTUI=1
    - Ran the command: netfx_Extended_x86.msi EXTUI=1

    The part I am unsure of is the EXTUI=1 syntax, but I think the above is correct. That's it.

    Friday, March 25, 2011 1:43 PM
  • It worked :-)

     

    Thanks alot

    Wednesday, May 25, 2011 9:00 AM