locked
InfoCard.exe memory access problem(s) RRS feed

  • Question

  •  

    I have just re-experienced some faults with memory access supposedly from InfoCard.exe. I have MS Dev studios 6, 7, & 8 installed on a fully up to date vesion of XP Pro. I get prompted as to what I want to use for debugging purposes. The answer is none. Searching for information suggests I can safely remove InfoCard from control panel / add / remove programs. However it does not exist and there is nothing that even looks vaguely similar. Nothing else gives me memory access problems. I am tempted to delete the exe but... If anyone has suggestions it would be appreciated.

    Sunday, September 9, 2007 11:35 AM

All replies

  • Hi, same simpthoms over here!

    XP Pro up to date, .Net Framework 2&3, VS 6,7&8.

     

    One more thing, until this moring when I played with some MSN web spaces, there was no infocard.exe running on my system...

    Friday, October 5, 2007 11:58 PM
  • I have exactly the same problem. It says Caption:"Just-In-Time Debugging". An exception "System.ExecutionEngineException' has occured in infocard.exe .

     

    Thursday, October 11, 2007 7:36 AM
  • I am experiencing the same problem. I have Windows XP with SP2 and Visual Studio 2005 Professional Edition with SP1.

    Actually this does not occur always, but still it is something that disturbs. I tried to search the internet for a solution but have not found a proper one.

    Thursday, October 11, 2007 10:50 AM
  •  

    I have the exact same problem as well.

    I think you can just kill the process with Windows Task Manager to stop this from happening.

     

    Does anyone even know what infocard.exe is for?

    Friday, October 12, 2007 10:19 PM
  • infocard.exe is a new application included with the .Net Framework 3.0.

    You can find it in Control Panel with the name "Windows CardSpace". It is a client software that enables users to provide their digital identity to online services in a simple and secured way.

    You can find information about it in the following:

     

    http://cardspace.netfx3.com/content/introduction.aspx

    http://msdn2.microsoft.com/en-us/library/aa480189.aspx

     

     REALfreaky wrote:

    I think you can just kill the process with Windows Task Manager to stop this from happening.

     

    Your solution to kill the process is good, but we hope we can find a solution that fixes this problem while keeping the process running because I think this service will not work unless its process is running. I have never tried it.

    Friday, October 12, 2007 10:45 PM
  • Hello,

    I have Windows Vista 9 and installed Microsoft Access from Office 2000. It worked fine for a month but just yesterday it refused to open any Access files, coming up with message Error 3000. Does anyone have any ideas about this? All other programmes in Office 2000 (Word, Excel, etc) still work fine.

    Friday, October 19, 2007 11:59 AM
  • I am experiencing the same problems multiple times throughout the day.  In addition to killing the process in Windows Task Manager, you can try this, too, until MS comes up with a way to address the memory access problem.

      

    Open up Services and disable Windows CardSpace.  Be sure to set Recovery options to Take No Action and to disable the service for any Hardware Profiles defined under Log On.

     

    Just remember to start the service again once MS posts a KB work-around on this issue!

    Wednesday, October 24, 2007 7:31 PM
  • Freshly installed computer with all the development tools and now on the next day the first exception like this.... it is unbelievable, that windows starts annoying me only 8 hours after finishing all the installations...

     

    Friday, November 2, 2007 3:01 PM
  •  

    At least I could retrace my steps and figure out that it was the single sign on assistant from the MSN Messenger that seemed to have caused the problem. I uninstalled it and now it is running exception free so far...
    Friday, November 2, 2007 3:22 PM
  • I too have had this same problem for the past few days.  I turned on my updates last weekend and upgraded to the latest and have been seeing this error for the past couple of days.  Thanks to those that have offered the solution of shutting off the service.  I've tried that and will report back if I still have issues.

    Thanks

    Greg

    Tuesday, November 6, 2007 5:53 PM
  • 12 january 2009,
    updated XP, several Visual Studios.

    Same problem.

    Did I miss an uodate? Did Microsoft break infocard AGAIN?
    Monday, January 12, 2009 1:29 PM