none
Re-Deploy workflow manager failing (The Fabric Data Collection Agent is disabled for this deployment) RRS feed

  • Question

  • After removing all workflow manager databases, all service bus databases and deleting the site in IIS I wanted to reinstall the Workflow farm. However upon deployment I always get a "The Fabric Data Collection Agent is disabled for this deployment" error. Is there some way to repair install the workflow manager?

    PS C:\Users\SPDev> Add-SBHost -SBFarmDBConnectionString 'Data Source=test.test.LOCAL;Initial Catalog=SbManagementDB;Integrated Security=True;Encryp
    t=False' -RunAsPassword $SBRunAsPassword -EnableFirewallRules $true -Certificate
    AutoGenerationKey $SBCertificateAutoGenerationKey -Verbose;
    VERBOSE: [05.07.2013 14:46:04]: Validating input and configuration parameters.
    VERBOSE: [05.07.2013 14:46:05]: Installing auto-generated certificate.
    VERBOSE: [05.07.2013 14:46:07]: Granting 'Log on as Service' privilege to the
    run as account.
    VERBOSE: [05.07.2013 14:46:07]: Windows Fabric configuration started.
    VERBOSE: [05.07.2013 14:46:08]: Windows Fabric cluster manifest generated.
    VERBOSE: [05.07.2013 14:46:08]: Running Windows Fabric deployment.
    Add-SBHost : Program C:\Program Files\Windows
    Fabric\bin\Fabric\Fabric.Code.1.0\FabricDeployer.exe exited with error:
    Windows Fabric deployment failed.DeploymentValidator: warning: The Fabric Data
    Collection Agent is disabled for this deployment.
    DeploymentValidator: warning: The Fabric Data Collection Agent is disabled for
    this deployment.
    None of the declared nodes is for the current machine.
    The current deployed cluster manifest is invalid. Possible post deployment
    corruption of cluster manifest
    At line:1 char:1
    + Add-SBHost -SBFarmDBConnectionString 'Data
    Source=MCMSPDEV03.DEV.LOCAL;Initial C ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : NotSpecified: (:) [Add-SBHost], InvalidOperation
       Exception
        + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.Servi
       ceBus.Commands.AddSBHost

    Friday, July 5, 2013 12:55 PM

All replies

  • did you unconfigure workflow manager before manually deleting the databases?
    Monday, July 8, 2013 5:20 AM
  • I did not. What settings may I remove manually to "unconfigure" it? Some registry keys?
    Monday, July 8, 2013 8:18 AM
  • i'll have to get back. meanwhile, can u try unconfiguring workflow manager and see what happens? it may not complete given that the databases were removed manually, but it may end up cleaning some of the entries allowing a successful reconfiguration.

    i would also try uninstalling the following (in this order):

    * Workflow Tools (dont remember exactly what its called)

    * Workflow Manager

    * Workflow Client

    * Service Bus Server

    * Windows Fabric

    and the re-install, in the hope that it also can remove the stale entries

    Monday, July 8, 2013 8:24 AM
  • Just because I don't want to mess up more things: Isn't Windows Fabric also needed by the Distributed Cache of SharePoint or is "Windows App Fabric" something totally different? Just wondering.
    Monday, July 8, 2013 8:31 AM
  • Windows App Fabric is different.
    Monday, July 8, 2013 8:32 AM
  • I tried uninstalling the order you suggested, I could not uninstall the CU1 for Workflow Manager & Service Bus. When uninstalling I just get the error "An internal error has occured". Unfortunately I cannot re-reinstall either as I don't have that option in Web platform installer.

    Besides the CU1, the workflow manager could be installed again and configured as well - I just want to re-install the CU1 now.

    • Edited by Dennis Gaida Wednesday, July 10, 2013 5:13 AM more info
    Wednesday, July 10, 2013 5:06 AM
  • I didn't understand your last reply - are you saying that you were able to install Workflow Manager and configure it too, but you're now facing an issue when you install CU1?
    Wednesday, July 10, 2013 1:31 PM
  • btw, for your original issue (where you had deleted the databases) and were facing issues in Add-SBHost; try running the Remove-WFHost command.
    Wednesday, July 10, 2013 1:33 PM
  • Sorry for the confusing message. The way you said to uninstall all products and reinstall worked.

    I could not uninstall the CU1 updates - but after reinstalling everything and configuring a workflow farm, I could uninstall the CU1 updates and reinstall them again.

    The newest and funnest problem is now, after associating and starting a simple workflow:

    "Invalid JWT token. Could not resolve issuer token. Token contains invalid signature."

    I did a full userprofile synch and re-registered the workflow farm with the -force parameter. What else can I try?

    The workflow farm is running as a "sp_workflow" user account. I'm not trying to execute the workflow as the SYSTEM user, but rather with a farm administrator ("developer"). Fiddler doesn't show anything special besides the said error message - the security token just seems of. Can I reset something in SharePoint? Create a new App Management database, would that help? Doesn't the workflow manager use the App Management DB?


    ---

    Full Error:

    RequestorId: eaa01747-96ef-314b-0000-000000000000. Details: RequestorId: eaa01747-96ef-314b-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 401 {"error_description":"Invalid JWT token. Could not resolve issuer token."} {"x-ms-diagnostics":["3000006;reason=\"Token contains invalid signature.\";category=\"invalid_client\""],"SPRequestGuid":["eaa01747-96ef-314b-bcec-5d240fb6b9c7"],"request-id":["eaa01747-96ef-314b-bcec-5d240fb6b9c7"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["5"],"SPIisLatency":["0"],"Server":["Microsoft-IIS\/8.0"],"WWW-Authenticate":["Bearer realm=\"dcd4eb6a-d7af-49ea-bf2d-d4e5cf8b2722\",client_id=\"00000003-0000-0ff1-ce00-000000000000\",trusted_issuers=\"00000005-0000-0000-c000-000000000000@*,00000003-0000-0ff1-ce00-000000000000@dcd4eb6a-d7af-49ea-bf2d-d4e5cf8b2722\"","NTLM"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4481"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Wed, 10 Jul 2013 16:09:47 GMT"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutorexecutor, BookmarkManager bookmarkManager, Location resultLocation)

    ------

    Fiddler Trace:

    Because of length posted to Pastie:

    Pastie Link with Fiddler Trace

    • Edited by Dennis Gaida Wednesday, July 10, 2013 4:29 PM more links
    Wednesday, July 10, 2013 4:07 PM
  • Sorry for the delay in getting back - I don't know much about how SharePoint configures/uses WFM. Is there another SharePoint forum you can ask on? I will anyways try and find someone knowledgeable about SP to look at this.

    WFM doesn't use the App Management DB (I take it that is a SharePoint DB).

    Thursday, July 18, 2013 11:48 AM
  • For this part of the question, can you reach out to SH2013 community here

    http://social.msdn.microsoft.com/Forums/sharepoint/en-US/home?forum=sharepointgeneral

    someone there could help


    Ravi Sekhar

    Thursday, July 18, 2013 11:54 AM