none
Visual Studio XAML Designer crash

    Question

  • Hi! I've just created empty Universal App in Microsoft Visual Studio Enterprise 2015 Version 14.0.25123.00 Update 2 on my Windows 10 Pro x64 PC and the problem is that when I open MainPage.xaml in designer it crashes with the error shown on the screenshot. What I've tried: changing permissions and owner of ReferenceAssemblies folder(both in Program Files and Program Files x86, according to the answer from this topic https://social.msdn.microsoft.com/Forums/vstudio/en-US/388dd1c5-ca01-4538-baa8-7555100e4f80/visual-studio-12-designer-could-not-be-started-because-of-a-permissions-issue?forum=vseditor), clearing ShadowCache in AppData, checking registry keys as described here http://stackoverflow.com/a/17137736/1666284, Repairing Visual Studio from Uninstall and change programm menu, running VS as admin and nothing of the above did help.


    Sunday, April 17, 2016 2:42 PM

Answers

  • Actually, what I found out, this problem is a bug with VS/Windows10 when user manually changes Windows settings to install Store apps to not-system drive(not C) and after that installs Visual Studio to that drive. Here is another topic started by me on Microsoft Connect where you can find additional info https://connect.microsoft.com/VisualStudio/feedback/details/2602290/designer-crashing-for-any-universal-application
    Friday, April 22, 2016 2:22 PM

All replies

  • Try this

    Enter in control panel -> Program and files, find one of this three Windows Software development Kit select and click RMB and select change.

    Sunday, April 17, 2016 8:42 PM
  • Just tried changing both SDKs(10.0.26624 and 10.0.10586.212) and selecting all available components, but that didn't help. Also I've done full reinstallation of Win10(via reset in settings) and clean installation of VS and it still doesn't work.
    Sunday, April 17, 2016 10:34 PM
  • Thanks for Vizaint's help.

    Hi Andrew Nikolin,

    Please check whether you have checked all Universal Windows App Development Tools and Windows 8.1 and Windows Phone 8.0/8.1 Tools from Control Panel -> Programs and Features -> Visual Studio 2015 -> Change -> Modify.

    If all installed, please check whether your Windows 10 has installed all updates. Please check from All Programs -> Settings -> Update & Security -> Windows Update. And please also check whether you have turn on the Developer mode in the For Developer tab.

    In addition, do you use Visual Studio ISO installer? If no, please download a ISO installer to install your Visual Studio. Before installing, please make sure whether the package is well. Please use FCIV.exe http://support.microsoft.com/kb/841290 to verify hash of the ISO. Any discrepancy would indicate that the file was corrupted.

    The sha1 value of ISO, please refer to:

    https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Monday, April 18, 2016 7:02 AM
    Moderator
  • It'd be too obvious if I forgot to mark those SDKs :D They are all marked and installed, Windows updates show "Your device is up to date" and I'm using ISO downloaded via DreamSpark Premium from my university, which contains vs_enterprise.exe, folders "packages" and "Standalone Profiler"(I'm not sure which version of VS it contains, because it automatically gives me an option to install Update 2, but I've downloaded it a long time ago). Btw, designer for Windows Phone 8/8.1 projects works seamlessly. Developer mode is enabled. Computing hash gave me that info 07c949078f895ce0d9c03a1b8d55571a8c90ac94 en_visual_studio_enterprise_2015_x86_x64_dvd_6850497.iso

    Maybe I can try to download Enterprise trial installer and activate it with my license key?

    Some strange things I've noticed: I can compile Universal Windows 10 projects, but there are no ARM emulators available even after installing them manually from developer.microsoft.com/en-us/windows/downloads/sdk-archive
    • Edited by Andrew Nikolin Monday, April 18, 2016 11:06 AM Updated with strange things
    Monday, April 18, 2016 8:09 AM
  • Hi Andrew Nikolin,

    According to the SHA-1 value for your installer, it should be Visual Studio 2015 Enterprise RTM version, which is not include the Update 2.

    >> Maybe I can try to download Enterprise trial installer and activate it with my license key?

    If your license key is a enterprise version license, please download the Visual Studio 2015 Enterprise with Update 2 installer from below link and then install it.

    https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx

    Before installing, please uninstall your Visual Studio with following steps.

    1. Uninstall Visual Studio from Control Panel -> Programs and Features -> Visual Studio 2015 Enterprise -> Change -> Uninstall.
    2. Please use msiinv tool to list all installed msi on your OS. Then check whether there has any component related Visual Studio 2015. If yes, please try the msiexec /x<product code> to remove that component. Please refer to this blog.
    3. Close all third part program when installing Visual Studio, such as antivirus software.
    4. Run the new downloaded installer as administrator to make sure it has enough permission to do any operations when installing.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Tuesday, April 19, 2016 1:47 AM
    Moderator
  • Actually, what I found out, this problem is a bug with VS/Windows10 when user manually changes Windows settings to install Store apps to not-system drive(not C) and after that installs Visual Studio to that drive. Here is another topic started by me on Microsoft Connect where you can find additional info https://connect.microsoft.com/VisualStudio/feedback/details/2602290/designer-crashing-for-any-universal-application
    Friday, April 22, 2016 2:22 PM
  • Hi Andrew Nikolin,

    I'm glad that you have found out the problem and thanks for sharing your workaround here. Please mark your reply as answer and then waiting for the response from Visual Studio Connect. It is benefit to other communities who has the same problem and they can vote and add comments for your feedback.

    If any questions about Visual Studio IDE in future, please feel free to come back to our forum. Thanks for your feedback for Visual Studio product.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Monday, April 25, 2016 1:19 AM
    Moderator