locked
Volume Control Options - Check/uncheck of the devices that I want to play sounds doesn't work

    Question

  • Hi everyone,

    I really like the idea of the new Volume Control Options. To access them you right click on the volume icon in the task bar (Desktop). When you choose Volume Control Options, a window pops up, where you can check / uncheck the devices you want to play sounds.

    Unfortunately it doesn't work for me. I can tick and un-tick the HDMI Output as much as I want... it wont work.

    Is anyone else having these problems?

     

    Also I would like to make a suggestion. I would very much like to be able to define which audio devise shall play the sounds of which program. So for example I could let my home theater system play the sounds of VLC Mediaplayer, while system sounds, IE and Skype are being played via the internal speakers of my laptop.

    I would also like Windows to remember my settings. So imagine you are on the road and open VLC Player to watch a movie. It will play the sound on the Laptop speakers (there is no other sound system connected, after all). Back at home I plug in my HDMI cable to continue watching the movie. Windows automatically switches the sound output of VLC to the TV or the home theater system.

    Wouldn't that be great? What do you guys think?


    Sunday, October 16, 2011 5:21 PM

Answers

  • Thank you for posting your feedback, we want to make sure we get the right info including your log files. Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.

    If you are prompted for an invitation code, please enter the following key. MSDN-76H9-3CFP

    https://connect.microsoft.com/site1147/InvitationUse.aspx?ProgramID=7221&InvitationID=MSDN-76H9-3CFP


    Marilyn
    Tuesday, October 18, 2011 8:09 PM
    Moderator

All replies

  • When you choose Volume Control Options, a window pops up, where you can check / uncheck the devices you want to play sounds.

    Unfortunately it doesn't work for me. I can tick and un-tick the HDMI Output as much as I want... it wont work.

    You probably need to install video drivers for your HDMI graphic card.

     

    Have you installed the newest drivers? If not download them from the manufacturers website. Some drivers might be available using Windows update. 

    Since Windows 8 has not been released yet not all drivers are going to work with it. Some drivers are very specific about the operating system version, so you might have to wait until they release Windows 8 drivers (if they make them for your model).
     


    If the drivers don't install, try installing them in compatibility mode.

    Troubleshoot Compatibility

    This can help with some (but not all) programs/drivers:
    1) Uninstall the program if it's already installed. Then when you install/reinstall it instead of double clicking on the install file right click it and select "Troubleshoot Compatibility"
    2) Then click "Try Recommended Settings" and in the next windows click "Start the Program" to install it.
    3) After it installs see if it works correctly. Please note - some programs may not be able to run in Windows 8.

     

     

     

    If you have drivers installed:

    Is the sound device enabled, and set as default?
    A. On the desktop, right-click the speaker icon on your taskbar
    B. Select "Playback Devices"
    C. In the white empty space right click and select both Show Disconnected/Disabled Devices
    D. Do you see icons for your device? 
    E. If you now see it you may need to right click on the correct sound device and select "Set as default device"

     

    Open The Audio Troubleshooter

    1. In Metro type: Troubleshoot
    2. Click Settings.
    3. Click Troubleshooter
    4. Click Troubleshoot Audio Playback

     

    Sunday, October 16, 2011 5:42 PM
  • thanks for the quick reply. updating the driver didn't work, unfortunately.

    And there are now additional devices among the Playback Devices. That is the way I use HDMI output though (by setting it as the default device).

    So maybe I have to wait some time until the new functionality works for me.

    Thanks anyway

    Sunday, October 16, 2011 8:51 PM
  • Thank you for posting your feedback, we want to make sure we get the right info including your log files. Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.

    If you are prompted for an invitation code, please enter the following key. MSDN-76H9-3CFP

    https://connect.microsoft.com/site1147/InvitationUse.aspx?ProgramID=7221&InvitationID=MSDN-76H9-3CFP


    Marilyn
    Tuesday, October 18, 2011 8:09 PM
    Moderator