locked
SharePoint 2013 Patch level is ambiguous after installing May CU RRS feed

  • Question

  • Hello all,

    I recently installed SharePoint 2013 with SP1 on a three-server farm (1 app, 1 WFE, 1 SQL with everything up to specs. Can provide more info if needed). 

    The SQL version my organization wanted to use is 2014, so I installed May CU per https://technet.microsoft.com/en-us/library/cc262485.aspx.

    I ran the configuration wizard on each server and rebooted each server. 

    This appeared to install successfully. However, there is now some confusion about what version I'm on. 

    Control Panel -> Uninstall a program says I am on 15.0.4569.1506. 

    Servers in Farm in CA says: 15.0.4605.1002

    Check Product and Patch Installation Status in CA says 15.0.4569.1506 on every other line, and 15.0.4605.1004 on every other line. I don't think that's normal, can someone please advise. 

    So that's three different version numbers. 

    The version number articles (http://blogs.technet.com/b/steve_chen/archive/2013/03/26/3561010.aspx) say that I'm on SP1 (1506) or April CU (1004). 1002 isn't even mentioned here, nor do I see a number for May CU (which exists: https://support.microsoft.com/en-us/kb/2878240).

    I have tried running config wizards again and restarting again. Everything runs successfully but version numbers don't change. 

    Any help on how to correct this situation is much appreciated. 

    Thanks,

    Shae






     
    Monday, May 11, 2015 5:18 PM

Answers

  • This tells me I have SP1 installed w/ the April 2015 CU. Each major product ("Microsoft Access Services English Language Pack") will have the major build number on the same line, with any updates listed below.

    Note that you need to download and install SP1. The SP1 you have will not let you update to the April 2015 or higher security patches/CUs.


    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by Shae Says Tuesday, May 12, 2015 12:00 AM
    Monday, May 11, 2015 6:15 PM
  • That is the "bad" SP1. See:

    http://thesharepointfarm.com/2015/04/april-updates-unable-to-install-on-service-pack-1/

    http://thesharepointfarm.com/2015/04/list-of-good-sharepoint-2013-service-pack-1-packages/


    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by Shae Says Monday, May 11, 2015 11:59 PM
    Monday, May 11, 2015 6:40 PM

All replies

  • Yes that can and is absolutely normal. Not all patches apply, and the major version is listed for each product.

    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, May 11, 2015 6:11 PM
  • This tells me I have SP1 installed w/ the April 2015 CU. Each major product ("Microsoft Access Services English Language Pack") will have the major build number on the same line, with any updates listed below.

    Note that you need to download and install SP1. The SP1 you have will not let you update to the April 2015 or higher security patches/CUs.


    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by Shae Says Tuesday, May 12, 2015 12:00 AM
    Monday, May 11, 2015 6:15 PM
  • Thanks, Trevor. That's very helpful. 


    Can you elaborate on this:

    "Note that you need to download and install SP1. The SP1 you have will not let you update to the April 2015 or higher security patches/CUs."

    I thought I had SP1 installed (15.0.4569.1506)? Are you saying I need to get this one?
    --------------------------------------
    SP1-released Apr.2014

    (15.0.4569.1509)
    fixed Build:
    15.0.4571.1502

    SP -
    2817439
    2760625 - Fix
    2880551 - Current

    yes
    Known Issue
    -
    Re-released
    --------------------------------------

    That one has a foundation-only KB number. Would I install that on server?

    And is this required even if I don't have issues to fix by later CUs at this time?

    Thanks,

    Shae







    • Edited by Shae Says Monday, May 11, 2015 8:55 PM
    Monday, May 11, 2015 6:38 PM
  • That is the "bad" SP1. See:

    http://thesharepointfarm.com/2015/04/april-updates-unable-to-install-on-service-pack-1/

    http://thesharepointfarm.com/2015/04/list-of-good-sharepoint-2013-service-pack-1-packages/


    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by Shae Says Monday, May 11, 2015 11:59 PM
    Monday, May 11, 2015 6:40 PM
  • I had no idea there was a "bad" one. Thanks for that info!

    Can I go ahead and install the good one now on top of what I've got in place? Or do I need to roll something back or squeeze any other updates in there first?

    Thanks,

    Shae

    Monday, May 11, 2015 6:48 PM
  • Yes, just install the good SP1 over the top.

    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, May 11, 2015 6:48 PM
  • OK, I installed the good SP1 on the app server and then the WFE. When I went to run psconfig on the app server, I now get a message that I'm missing 45 things! Do I really need to find and install each of these individually, or is there something more basic I'm missing here? The first one doesn't even have a link explaining where to get it. Help!

    Thanks,

    Shae

    Microsoft SharePoint Server 2013 Installed Across Server Farm 
     Microsoft SharePoint Foundation 2013 Core 
      
     Microsoft SharePoint Foundation 2013 Core (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Foundation 2013 1033 Lang Pack 
      
     Microsoft SharePoint Foundation 2013 1033 Lang Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Server Proof (Arabic) 2013 
      
     Microsoft Server Proof (Arabic) 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Server Proof (German) 2013 
      
     Microsoft Server Proof (German) 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Server Proof (English) 2013 
      
     Microsoft Server Proof (English) 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Server Proof (French) 2013 
      
     Microsoft Server Proof (French) 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Server Proof (Russian) 2013 
      
     Microsoft Server Proof (Russian) 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Server Proof (Spanish) 2013 
      
     Microsoft Server Proof (Spanish) 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Portal 
      
     Microsoft SharePoint Portal (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft User Profiles 
      
     Microsoft User Profiles (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Portal English Language Pack 
      
     Microsoft SharePoint Portal English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Shared Components 
      
     Microsoft Shared Components (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Shared Coms English Language Pack 
      
     Microsoft Shared Coms English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Slide Library 
      
     Microsoft Slide Library (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft InfoPath Forms Services 
      
     Microsoft InfoPath Forms Services (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft InfoPath Form Services English Language Pack 
      
     Microsoft InfoPath Form Services English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Word Server 
      
     Microsoft Word Server (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Word Server English Language Pack 
      
     Microsoft Word Server English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     PerformancePoint Services for SharePoint 
      
     PerformancePoint Services for SharePoint (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     PerformancePoint Services in SharePoint 1033 Language Pack 
      
     PerformancePoint Services in SharePoint 1033 Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Visio Services English Language Pack 
      
     Microsoft Visio Services English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Visio Services Web Front End Components 
      
     Microsoft Visio Services Web Front End Components (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Excel Services Components 
      
     Microsoft Excel Services Components (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Document Lifecycle Components 
      
     Microsoft Document Lifecycle Components (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Excel Services English Language Pack 
      
     Microsoft Excel Services English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Search Server 2013 Core 
      
     Microsoft Search Server 2013 Core (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Search Server 2013 English Language Pack 
      
     Microsoft Search Server 2013 English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Document Lifecycle Components English Language Pack 
      
     Microsoft Document Lifecycle Components English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Slide Library English Language Pack 
      
     Microsoft Slide Library English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Server 2013  
      
     Microsoft SharePoint Server 2013 (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Web Analytics Web Front End Components 
      
     Microsoft Web Analytics Web Front End Components (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Web Analytics English Language Pack 
      
     Microsoft Web Analytics English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Excel Mobile Viewer Components 
      
     Microsoft Excel Mobile Viewer Components (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Workflow Solutions Framework 
      
     Microsoft Workflow Solutions Framework (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Workflow Solutions Framework English Language Pack 
      
     Microsoft Workflow Solutions Framework English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Education 
      
     Microsoft Education (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Education English Language Pack 
      
     Microsoft Education English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Foundation 2013 1033 SQL Express 
      
     Microsoft SharePoint Foundation 2013 1033 SQL Express (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Office PowerPoint Services 
      
     Microsoft Office PowerPoint Services (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Office PowerPoint Services English Language Pack 
      
     Microsoft Office PowerPoint Services English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Access Services Server 
      
     Microsoft Access Services Server (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft Access Services English Language Pack 
      
     Microsoft Access Services English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Multilingual Solutions English Language Pack 
      
     Microsoft SharePoint Multilingual Solutions English Language Pack (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Microsoft SharePoint Multilingual Solutions 
      
     Microsoft SharePoint Multilingual Solutions (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
     Service Pack 1 for Microsoft SharePoint Server 2013 (KB2880552) 64-Bit Edition (15.0.4571.1502)  
     Missing on SERVERNAMEAPP01 
    


    • Edited by Shae Says Monday, May 11, 2015 8:21 PM
    Monday, May 11, 2015 8:17 PM
  • Run:

    Get-SPProduct -Local

    Wait 5 or so minutes and try again.


    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, May 11, 2015 8:18 PM
  • And by the way I have not installed any language packs so I don't know where that's coming from. 

    Also, I have installed the trial version but I plan to install service applications and use as SharePoint server (dev), not Foundation. 

    Thanks,

    Shae

    Monday, May 11, 2015 8:23 PM
  • If you used the English bits, it will have the Eng LP. You do not have to do anything but apply Eng SP1 to update those bits. That said, have you tried my previous suggestion?

    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, May 11, 2015 8:39 PM
  • Thanks Trevor. I posted my second post before I saw your suggestion. Yes, that did indeed work. Thanks! That one scared me for a moment :)

    So now I have this:

    Control panel: 15.0.4571.1502

    Patch status: 15.0.4571.1502 / 15.0.4605.1004 depending on line

    Servers in farm: 15.0.4605.1002


    So a final question... my goal here was to get the required CU for using SQL 2014 (https://technet.microsoft.com/en-us/library/cc262485.aspx says "SQL Server 2014 requires the May 2014 Cumulative Update to be installed").

    Am I there yet? The article (https://support.microsoft.com/en-us/kb/2878240) says it is build 15.0.4605.1004, which makes an appearance on my Patch status page. But I had tried that install before getting the "good" SP1, so now I'm not sure.

    Thanks again for all your help. 


    Monday, May 11, 2015 8:53 PM
  • That should be OK. By the way, the SQL 2014 support is really only for the User Profile Service. I would say that you may want to consider the March 2015 CU + April 2015 security patches, or April 2015 CU (which includes the sec patches). This way you're up-to-date on deployment with security patches, at least.


    Trevor Seward

    Follow or contact me at...

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, May 11, 2015 8:55 PM
  • Thanks Trevor. You have been a HUGE help!

    Shae

    Tuesday, May 12, 2015 12:00 AM