none
.net framework v 2.0 required RRS feed

  • Question

  • I am totally @ a loss...I have tried everything! I keep getting an error message when trying to use certain things on my computer (i.e. printivity on printer) stating "Microsoft .net framework version 2.0 is required to use this feature" or something along those lines. Then when I try to install the message either says, "this product is not compatible w/the 64 bit operating system" or "you already have this product." And when I look in the add/remove programs I can't locate this software anywhere! I did a restore recovery about 2w ago when HP walked me through, but I know there's got to be a better way then going through that again? I'm running windows 7 64-bit...ALL help would be appreciated! Thanks!
    • Moved by Paul Zhou Monday, June 6, 2011 7:05 AM (From:64-Bit .NET Framework Development.)
    Thursday, June 2, 2011 4:20 PM

Answers

  • Hi DivaLiya,

    Thanks for your post.

    According to your description, it appears that the .NET Framework in your system might be corrupted or have some errors.

    I would suggest you firstly verify the install status of .NET Framework with .NET Framework Setup Verification Tool.

    If the tool reports verify failed. Please follow the steps below to repair .NET Framework in your system:

    1. Go to Start menu >> Control Panel >> Programs >> Turn Windows features on or off;
    2. Unselect Microsoft .NET Frameowork 3.5.1 in the Windows Feature window, if it is selected. Click OK;
    3. Reopen Windows Feature window, select Microsoft .NET Frameowork 3.5.1 and its sub items, click OK.

    If you have any concerns, please feel free to let me know.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 6, 2011 9:52 AM
    Moderator

All replies

  • I also forgot to mention that this error occurred after doing the installed updates that windows prompted me after the recovery!
    Thursday, June 2, 2011 4:23 PM
  • I'm moving this thread to .NET Framework Setup forum to get better support.

    Have a nice day!


    Paul Zhou [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 6, 2011 7:05 AM
  • Hi DivaLiya,

    Thanks for your post.

    According to your description, it appears that the .NET Framework in your system might be corrupted or have some errors.

    I would suggest you firstly verify the install status of .NET Framework with .NET Framework Setup Verification Tool.

    If the tool reports verify failed. Please follow the steps below to repair .NET Framework in your system:

    1. Go to Start menu >> Control Panel >> Programs >> Turn Windows features on or off;
    2. Unselect Microsoft .NET Frameowork 3.5.1 in the Windows Feature window, if it is selected. Click OK;
    3. Reopen Windows Feature window, select Microsoft .NET Frameowork 3.5.1 and its sub items, click OK.

    If you have any concerns, please feel free to let me know.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, June 6, 2011 9:52 AM
    Moderator