locked
Python-Django Web IIS configuration on VM RRS feed

  • Question

  • User-1715881447 posted

    Hello guys,

    i configured IIS for python Django web Application on VM but i am getting this error. anyone have any idea how to solve this error thanks in advanced 

    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler Python FastCGI
    Error Code 0x8007010b
    Requested URL http://localhost:8003/
    Physical Path C:\inetpub\wwwroot\KPMG_KRX
    Logon Method Anonymous
    Logon User Anonymous

    Wednesday, February 6, 2019 7:35 AM

All replies

  • User690216013 posted

    https://blog.lextudio.com/shifting-to-azure-app-service-on-linux-b216f4584b03

    It is time to run Python on Linux again. Microsoft no longer makes Windows/IIS a suitable option for you.

    Wednesday, February 6, 2019 3:29 PM
  • User-1715881447 posted

    hi lex thanks to replay me so there is video on YouTube show that its possible to deploying python-Django web Application on azure VM (window server) and i try that but its given me error 500.0 internal server error so what is issue. or i have not try that and switch to Linux environment can you please guide me thanks in advanced my Email id: hastikpatel786@gmail.com

    Thursday, February 7, 2019 4:30 AM
  • User690216013 posted

    Hastik

    its possible to deploying python-Django web Application on azure VM

    Anything is possible, but you have to find your own way when Microsoft no longer supports it. Neither do I.

    Thursday, February 7, 2019 5:15 AM
  • Thursday, February 7, 2019 5:49 AM
  • User-1715881447 posted

    hi Jalpa,

    i already did all the thing installation of python,wfastcgi, adding handler and other thing. i follow this video both video mostly are same and in first video link there is solution of my error is give and i try that also but still i am getting error 

    link

    https://www.youtube.com/watch?v=CpFU16KrJcQ

    https://www.youtube.com/watch?v=cgTFrAwXeoI&t=1s

     and error is HTTP error 500.0 internal server error unknown fastcgi occurred 

    Thursday, February 7, 2019 6:12 AM
  • User-848649084 posted

    Hi,

    You need to be sure that the The scriptProcessor attribute of the web.config matches Full Path and the Arguments of the FastCGI application.

    Thursday, February 7, 2019 6:41 AM
  • User-1715881447 posted

    Hi,

    yes its correct config already 

    This my web config file

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <handlers>
    <add name="Python FastCGI"
    path="*"
    verb="*"
    modules="FastCgiModule"
    scriptProcessor="c:\users\hastik\appdata\local\programs\python\python37\python.exe|c:\users\hastik\appdata\local\programs\python\python37\lib\site-packages\wfastcgi.py"
    resourceType="Unspecified"
    requireAccess="Script" />
    </handlers>
    </system.webServer>

    <appSettings>
    <!-- Required settings -->
    <add key="WSGI_HANDLER" value="KPMG.wsgi.application" />
    <add key="PYTHONPATH" value="C:\inetpub\wwwroot\KPMG_KRX" />
    <!-- Optional settings -->
    <add key="DJANGO_SETTINGS_MODULE" value="KPMG.settings" />
    </appSettings>
    </configuration>

    Thursday, February 7, 2019 6:49 AM
  • User2082626702 posted

    welll first of all your web.config file is ok that ceratinly is not the issue , not completely sure about this but i had the same problem that you had, what i did was first reinstalling python and its packages back into C: folder so the path would be shorter just c:\python\python37.... cant say that solved the error but i did it and stayed that way since, how we actually solved the error was with this https://www.programmersought.com/article/59043206697/ so basically says (with some images too) that you should go to the ISS into Application Pool -> Advanced Settings -> ID: ApplicationPoolIdentify then modify whatever is there with the default LocalSystem. 
    pd: also check on the ISS permissions on the django app file so it can be accessed

    Thursday, June 3, 2021 11:00 PM
  • User690216013 posted

    modify whatever is there with the default LocalSystem. 

    You opened a security black hole on this web server.

    Friday, June 4, 2021 1:18 PM