locked
Program Data not Getting into Package

    Question

  • Hi Everyone,

    I am creating a package of my app to test and I noticed that my data folder (containing all my UI images, buttons, etc) is not being included in it. When I do a Debug or Release build I have a Post Build Script in VS that runs and copies a folder named "data" and all its subfolders into a Debug\AppX\data or Release\AppX\data folder depending on the build target.

    So, when I build a Release target and make a package from that (using the Store->Create App Package... menu) I assumed that the Release\AppX\data folder would be copied over as well. Is this not the case? What folder should I be using?

    Thanks Much!

    Thursday, June 14, 2012 3:32 PM

All replies

  • The Appx packaging tool in VS requires the assets to be referenced and included in the project. Is that possible to do in your situation?

    David Lamb

    Friday, June 15, 2012 1:58 AM
    Moderator
  • I have been having a similar problem. (VS2012 Ultimate Windows 8 RP.  C++ DirectX Metro application)

    I was able to make change my VS project so that when I compiled and deployed, that it would find my data.  I did this with a Post Build event that copied all of the applications data to $(Configuration)\APP\AppX.

    I am now trying to build a test package that I can pass around my office, but I cannot figure out how to modify its process to include the required assets.  I'm following what is detailed here (http://msdn.microsoft.com/en-us/library/windows/apps/hh975357(v=vs.110).aspx)

    I am using Projects->Store->Create App Package.
    I let it use its default destination directory and versioning.

    It builds and signs the package just fine, but no data is included (The appX file is around 2.7MB when I have 500MB+ of data)

    In my situation, there are around 4K+ assets in an extensive folder layout, so adding each file as a referenced file inside of the VS project is not feasible.

    Is there another option?

    John Salmond


    Monday, July 2, 2012 8:17 PM