locked
Unable to connect shared data source to report service system using visual studio Business intelligence service RRS feed

  • General discussion

  • Hello friends

    Im trying to use pubs sample data source for a Report service project using BI dev studio.i actually connected data set to sql server man studio.whene im trying to connect it  in BI Dev of visual studio i encounter with this error :

    Unable to connect to data source 'pubs'.A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

    

     
    Friday, July 27, 2012 9:28 AM

All replies

  • This error message means that you were not able to connect to SQL Server. There can be any numbers of reasons for this:

    * You did not specify the server/instance name correctly.
    * SQL Server is not running.
    * You connected from a different computer, and SQL Server only accepts
      local connections.
    * You connected from a different computer, and there is a firewall.
    * There is a network problem etc.

    Since you talk about BI Dev Studio, I would assume that you are trying to connect to a local instance. Maybe you specified only "(local)" when you should have said (local)\SQLEXPRESS. But I can only guess, since I have no knowledge about your environment.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Friday, July 27, 2012 7:32 PM
  • This error message means that you were not able to connect to SQL Server. There can be any numbers of reasons for this:

    * You did not specify the server/instance name correctly.
    * SQL Server is not running.
    * You connected from a different computer, and SQL Server only accepts
      local connections.
    * You connected from a different computer, and there is a firewall.
    * There is a network problem etc.

    Since you talk about BI Dev Studio, I would assume that you are trying to connect to a local instance. Maybe you specified only "(local)" when you should have said (local)\SQLEXPRESS. But I can only guess, since I have no knowledge about your environment.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Thanks a lot for your helpful descriptions .I also tried to change servers name and the result was solving my problem. 

    Live together Die alone

    Friday, July 27, 2012 9:32 PM