none
RemoteDesktop and Network Level Authentication RRS feed

  • Question

  • Hi there, I have created a Virtual Machine in Azure and then captured an image of it.  Whenever I create a machine from that image the Remote Desktop connection only connects in the less secure mode without Network Level Authentication.

    If I login and change the Remote Desktop Connections setting to require Network Level Authentication, when I try to connect from my Windows 7 computer that the connection requires Network Level Authentication (fine), however my machine does support Network Level Authentication.  I am therefore not able to connect to the machine until I change it back to the less secure mode.

    No matter what I have tried will it allow me to connect when this setting is on.  Now the funny thing is that when the machine is created initially (using the pre-build Azure templates) it gets created with Network Level Authentication switched on and I can connect without a problem; it is only when I create the machine from "My Images" that I have this problem.

    Thanks

    Phil.

    Friday, July 27, 2012 8:35 PM

Answers

All replies

  • Hi,

    I am not sure i can 100% understand your question, you network authentication can works fine in which condition? And does this mean the setting is on, you cannot connect the VM?


    Please mark the replies as answers if they help or unmark if not. If you have any feedback about my replies, please contact msdnmg@microsoft.com Microsoft One Code Framework

    Monday, July 30, 2012 9:27 AM
    Moderator
  • Sorry, whenever I turn on network authentication I can't connect to the VM.  The only time I can connect to the VM is when I have network authentication turned off and then it doesnt ask me to pre-authenticate when starting the RDP session.
    Monday, July 30, 2012 7:48 PM
  • Hi,

    Base on my understanding the Network Level Authentication in Azure VM is enable defaultly, and i also try to enable it in my client OS system, i do this according this article, after i modify the registry and restart my computer and Remote Desktop still works at my side, so i cant reproduce your problem, it seems not a common issue. Would you like to check any other software or firewall block the RDP? As far as i know, RDP require your TCP and UDP port 3389 allowed in firewall settings. Would you like to have a look?

    http://www.smallbusinesscomputing.com/webmaster/article.php/3787386/Windows-Remote-Desktop-Configuring-a-Firewall-and-Router.htm

    BR,

    Arwind


    Please mark the replies as answers if they help or unmark if not. If you have any feedback about my replies, please contact msdnmg@microsoft.com Microsoft One Code Framework

    Tuesday, July 31, 2012 2:13 AM
    Moderator