Stable Release: Xamarin.iOS 9.0, iOS 9.0 upstream release RRS feed

  • Question

  • User13824 posted

    Visual Studio Extension

    • Xamarin.VisualStudio_3.11.1443.msi (39031d3)


    • ~~monotouch- (d230615)~~
    • monotouch- (d8e9592) Hotfix

    Reason for release: Updated SDK bindings and compatibility support for upstream iOS 9.0 and Xcode 7.0 Final versions.

    Release notes: http://developer.xamarin.com/releases/ios/xamarin.ios_9/xamarin.ios_9.0/

    Date published: See https://releases.xamarin.com/.

    NOTE: This is a feature release that contains a large number of changes compared to the previous Stable version. In addition to support for iOS 9 and Xcode 7, it contains larger changes to the existing parts of Xamarin.iOS than any of the recent smaller service releases. On top of that, as with any Xamarin version that is published in response to an upstream release, these builds have primarily been tested against preview versions of the upstream components. For these reasons the stability of this Xamarin.iOS 9 release is less certain than "Cycle" feature releases and service releases. It has passed the minimum threshold for being accepted to the Stable channel, but it has not undergone the more thorough and diverse user feedback process that Xamarin hopes to achieve via the upcoming "release candidate" for the Cycle 6 Stable feature release.

    Previous versions, downgrading

    You can downgrade back to the previous Stable version by manually reinstalling each old package. See the KB article on downgrading. If you have a Trial or Starter subscription (or simply would prefer an email with all the installer links you need), feel free to contact hello@xamarin.com to request the older versions.

    Older Mono package versions are not currently listed on https://store.xamarin.com/account/my/subscription/downloads. The Mono package for the previous Stable version ("Service Release 4") is available here:

    Guidelines for this thread

    1. This first post will be updated regularly.

    2. The goal of this thread is to help answer "what might break if I update to this release?"

    3. If you find a new problem that is specific to this version:

      a. If you can share some specific error messages or can reproduce the problem consistently, please email the information you have so far to contact+xamarinios9.0@xamarin.com.

      b. If you only have a general description of the problem, you can post it directly on this forum thread so that hopefully a member of the Xamarin team or another user will recognize it and be able to help fill in some details.

    New known issues in this release, with more common or severe issues near the top

    Many of these issues are fixed in the follow-up "service release" now available on the Beta updater channel.

    • Bug 33124 - [iOS] Certain libraries that were compiled by the Microsoft C# 5 compiler (VS 2013) cause "error MT2001: Could not link assemblies. Reason: Can't not find the nested type" during the linking phase of the Xamarin.iOS build process. (For example, any library compiled by VS 2013 that uses an async lambda within a constructor will hit this problem.) Unfortunately this problem affects several existing NuGet packages and Components. Now hotfixed in the Stable channel.

    • Non-public Bug 31424 - [Xamarin Studio] [iOS] Classic API on Mac only: "Resource rules files "" not found". Now fixed in the Beta channel. (Old partial workaround: Enable "Project Options -> General -> Use MSBuild build engine (unsupported for this project type)" and clean and rebuild the project. (The MSBuild build engine does now work for many Classic API projects.))

    • Non-public Bug 34163 - [XamarinVS] [iOS] Error similar to: "System.IO.FileNotFoundException: Could not find file "/Users/macuser/Library/Caches/Xamarin/mtbs/builds/Unified.ClassLibrary.iOS1/242ab4564ac5785ce41fda606805edad/obj/Debug/ibtool/IPhoneViewController1.nib"" or "System.IO.FileNotFoundException: Could not find file "/Users/macuser/Library/Caches/Xamarin/mtbs/builds/Unified.ClassLibrary.iOS1/242ab4564ac5785ce41fda606805edad/obj/Debug/optimized/buttonblack135x40.png"" when class library assembly name includes dot "." characters. Now fixed in the Beta channel. (Old temporary workaround: Change "Project properties -> Application -> Assembly name" so that it includes no "." characters. Change the project name to match the modified assembly name.)

    • Non-public Bug 34173 - [iOS] [Designer] Storyboard fails to load in designer with "There was a problem parsing the XML" for storyboards that contain a <constraint> element with an attribute of multiplier="0". Workarounds: Open the storyboard in Xcode Interface Builder and re-save it from there. Or edit the storyboard in a text editor and manually remove the multiplier="0" attribute.

    • Non-public bug 34202 - [XamarinVS] [iOS] Error similar to: "The OutputPath property is not set for project 'iOSClassLibrary1.csproj'. Please check to make sure that you have specified a valid combination of Configuration and Platform for this project. Configuration='Debug' Platform='iPhone'." after adding an iOS class library to a solution where an iOS app project is set as the startup project. Now fixed in the Beta channel. (Old temporary workaround: Open the iOS class library .csproj in a text editor and delete all occurrences of the following 2 strings: "|$(Platform)", "|AnyCPU".)

    • Non-public Bug 34144 - [XamarinVS] [iOS] Redeploying an app that references a library project without first cleaning the library project causes all resources to be replaced with 0-byte files if any of the resource files was modified. Now fixed in the Beta channel. (Old partial workaround: Clean the library project before redeploying the app.)

    • Bug 34220 - [iOS] The new iOS 9 ReplayKit APIs currently hit an error: "Cannot cast from source type to destination type". Now fixed in the Beta channel.

    • Bug 34205 - [iOS] Changes to WatchKit app storyboards do not appear on the simulator after the first deployment. Workaround: Manually delete the app from the iPhone simulator before re-deploying.

    • Bug 34186 - [iOS] "MTOUCH: error MT5212: Native linking failed, duplicate symbol" and "Duplicate symbol in: ... libmonotouch-sgen.a" errors appear if using the -all_load linker flag under "Additional mtouch arguments". Now fixed in the Beta channel. (Old partial workaround: remove the -all_load liker flag.)

    • Non-public Bug 34198 - [XamarinVS] [iOS] Visual Studio sometimes disallows loading Xamarin projects with: "An equivalent project (a project with the same global properties and tools version) is already present in the project collection". Temporary workaround: Attempt to load the project again, or if that still fails quit and reopen Visual Studio and then reload the project.

    • Non-public Bug 33706 - [iOS] Storyboards produce many warnings similar to: "/Applications/Xcode-beta.app/Contents/Developer/usr/bin/ibtool: 2015-09-04 18:01:03.651 Interface Builder Cocoa Touch Tool[72838:13678534] CoreUI: CUICatalog: couldn't get 'kMGArtworkGraphicsFeatureSetClass' from MGCopyAnswer got '{ (CollectionView)". These warnings can be ignored for now. The problem is that Xamarin is currently surfacing diagnostic messages from ibtool that are not surfaced by the default Xcode build process. Now fixed in the Beta channel.

    • Non-public Bug 34083 - [Xamarin Studio] [iOS] Install error message from iOS device logs: "0xe8008017 (Signed resources have been added, removed, or modified)". Xamarin Studio's "Archive for Publishing" feature does not currently work correctly for Xamarin.iOS 9 apps. It incorrectly removes a symlink for the application .exe, invalidating the Sealed Resources in the code signature. This is known to cause problems when installing apps from HockeyApp, and is likely to cause problems in other situations too. (The problematic symlink is a new feature of Xamarin.iOS 9.) Now fixed in the Beta channel. (Old workarounds: Option A: Follow the steps under "For command line builds on Mac" to build the IPA as part of the build process rather than using the "Archive for Publishing" workflow. Option B (advanced): manually add back the symlink.)

    • Non-public Bug 33819 - [XamarinVS] [iOS] Attempting to stop a WatchKit app in Glance mode does not stop the app. Workaround: Kill the app manually.

    • Bug 34054 - [Xamarin Studio] [iOS] Under certain conditions resuming from a breakpoint when debugging will cause a dialog box to pop up that asks "Where is iOS Simulator?" Now fixed in the Beta channel. (Old temporary workaround: Dismiss the dialog each time it appears.)

    • Non-public Bug 33695 - [iOS] Attempting to install a new version of an application on device using a different provisioning profile from the original install is not supported by Xcode 7. Unfortunately, the corresponding error message produced by Xamarin does not describe the problem clearly: "error MT1006: Could not install the application ... on the device ... Application Verification Failed Error (error: 0xe800003a)." This error message will be improved in a future release. Workaround: Manually uninstall the app from the device and try installing it again.

    • Non-public Bug 33880 - [Upstream] [iOS] Attempting to stop a WatchKit app in Notification mode does not stop the app. (The same problem occurs with an Objective-C or Swift app deployed from Xcode, so this is an upstream issue.) Workaround: Kill the app manually.

    • Non-public Bug 33847 - [Xamarin Studio] [iOS] The iOS device and simulator names are cut short in the device selector menu in Xamarin Studio. Workaround: Switch to a different application and then back to Xamarin Studio.

    • Non-public Bug 33888 - [XamarinVS] [iOS] VS 2010 only. Opening a second Xamarin.iOS solution when already connected to the build host causes VS to disconnect from the build host. The user must refresh the connection manually via the "Refresh build server info" button.

    Important changes introduced by Xcode 7 and iOS 9

    See also: https://developer.xamarin.com/guides/ios/platform_features/introduction_to_ios9/troubleshooting/ and http://developer.xamarin.com/guides/ios/platform_features/ios9

    • [iOS] [Designer] The Xamarin iOS designer does not yet support Xcode 7 features. Storyboards will fail to load in designer with "There was a problem parsing the XML" when attempting to use new iOS 9 (Xcode 7) designer elements such as StackView. iOS designer support for Xcode 7 features is targeted for the upcoming Cycle 6 feature release. (The preview version of Cycle 6 is currently available in the Alpha channel.) Partial workaround for Xamarin Studio: Right-click the storyboard and choose "Open With -> Xcode Interface Builder".

    • [Upstream change] [iOS] Xcode 7 produces new warnings similar to: "warning MT5203: Native linking warning: warning: object file ... was built for newer iOS version (8.1) than being linked (8.0)". This is a new warning introduced by Xcode 7 to help app developers avoid potential problems that were silently allowed in Xcode 6. It affects Objective-C and Swift apps too. The warning message is accurate. For example, if you want to set the minimum version of your app to iOS 8.0 then you should not link against libraries that were compiled using the iOS 8.1 toolchain. Otherwise you risk running into compatibility issues (or missing symbols). In other words, Apple does not guarantee that a library compiled against iOS 8.1 will work when linked into an application targeting iOS 8.0 or earlier. Options for how to fix: (a) if the library does not require the newer APIs, recompile it for the lowest API level you wish to support, or (b) if the library does require the newer APIs, the proper fix is to set the minimum supported version of the app to 8.1. Ways to silence the errors (not recommended): pass the "-w" option to the linker using the "Additional mtouch arguments" in the project options.

    • [Upstream change] [iOS] iOS 9 has stricter requirements for setting a RootViewController. "Objective-C exception thrown. Name: NSInternalInconsistencyException Reason: Application windows are expected to have a root view controller at the end of application launch". Possible workaround: Set the Window.RootViewController property in the AppDelegate.FinishedLaunching() method. (See the troubleshooting guide for additional details.)

    • [Upstream change] [iOS] "Could not find a paired Watch device for the iOS device". By default Xcode 7 ships with 38mm and 42mm WatchOS simulators paired with the iPhone 6 and iPhone 6 Plus simulators respectively. However the default iPhone 5 and iPhone 5s simulators are not paired with any Watch simulator. To add an iPhone 5 simulator that is paired with a WatchOS simulator, open "Window -> Devices" in Xcode, then press the "+" button to add new simulator. In the "Create a new simulator" window select the desired "Device Type" and then add the desired Apple Watch simulator version under "Paired Apple Watch".

    • [Upstream change] [iOS] "App Transport Security has blocked a cleartext HTTP (http://) resource load since it is insecure. Temporary exceptions can be configured via your app's Info.plist file." (See also Apple's corresponding tech note.). One way to workaround: Add an NSAppTransportSecurity key to the Info.plist. Under that key, add a dictionary that contains a single NSAppTransportSecurity key set to true: <key>NSAppTransportSecurity</key><dict><key>NSAllowsArbitraryLoads</key> <true/></dict>.

    • [Upstream change] [iOS] Starting in iOS 9, initialization code within UIView subclass IntPtr constructors will not run when the view is initialized from a XIB file. See http://developer.xamarin.com/guides/ios/platform_features/ios9/#UIView_fails_to_init_with_coder_when_loading_a_view_from_a_XibNib for additional details and workarounds.

    New issues in the Beta builds reported by users

    • Forum discussion 50492 - [Xamarin Studio] [iOS] "/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Error executing task DetectSdkLocations: Task does not have property "TargetFrameworkIdentifier" defined". Possible workarounds: Reboot the Mac. If that doesn't work, try reinstalling Xamarin.iOS.

    Fixes for known issues from recent release threads

    • Bug 31379, Bug 31560 - [iOS] Enabling the linker when the app references PCL projects that include "duplicate" System.Threading.Tasks references (for example when using the "Microsoft.Net.Http" NuGet in a .NET 4.0 PCL) causes "Could not load file or assembly 'System.Threading.Tasks'" on the simulator. This bug has in fact existed since the original April 29 release of Cycle 5, but until Service Release 2 it had been obscured by the closely related Bug 29211. The bug only affects simulator builds and has fairly easy workarounds, so it is minor in severity. Workarounds: disable the linker in the iPhoneSimulator configurations or add -linkskip=System.Threading.Tasks under "project options -> iOS Build -> Additional mtouch arguments".

    Remaining known issues from recent release threads

    Except for the "Fixes" mentioned above, the remaining known issues from the release threads are unchanged compared to Cycle 5 – Service Release 4.

    EDIT Sep 18: Add iOS Bug 33124. Add Xamarin Studio Bug 34083.
    EDIT Sep 21: Update Bug 33124 about candidate fix. Additional update: the fix is now on the Stable channel. Add XamarinVS.iOS Bug 34144.
    EDIT Sep 22: Add iOS Bugs 33706, 34502. Add Xamarin Studio Bug 34054. Add XamarinVS.iOS Bug 34163. Add iOS designer Bug 34173. Add known iOS designer limitation with StackView.
    EDIT Sep 23: Add XamarinVS.iOS Bug 34198. Add iOS Bug 34186.
    EDIT Sep 24: Add iOS Bug 34205. Add iOS Bug 34220.
    EDIT Sep 29: Indicate bugs now fixed on Beta channel (31424 34052 34224 34163 34202 34144 34220 34186 33706 34083 34054).

    Thursday, September 17, 2015 8:44 PM

All replies

  • User70 posted

    Looks like your Xamarin Studio installer is not setting XS to close on update. 5.9.7 (stable) stalls on update until XS is closed. I think someone forgot to set a restart option?

    Thursday, September 17, 2015 10:03 PM
  • User13824 posted

    Thanks for the heads-up! I had the team switch the setting, so it should now prompt anyone who upgrades to restart Xamarin Studio.

    Thursday, September 17, 2015 11:57 PM
  • User9348 posted

    I get; The installed Xamarin.iOS (version 8.10) on the Mac Build Host is not compatible with the local Xamarin.iOS 9.0. Double click here to select a new server.

    I checked all updates on my Mac, but everything has the latest version. I rebooted both machines, nothing helped.

    Friday, September 18, 2015 9:48 AM
  • User67478 posted

    Today I got the update message for compatibility to iOS 9. What I don't get is the message in the Mono Framework MDK

    Mono is a Beta build to support Apple's iOS 9 GM. We expect Stable support for iOS 9 to be released on Sept 16th, 2015. Please see https://releases.xamarin.com/beta-release-xamarin-ios-support-for-ios-9/ for more information.

    Is it still beta or not? If it is beta, why it is on the stable channel? If not, the message needs to be adapted.

    Friday, September 18, 2015 10:50 AM
  • User9348 posted

    Aaahhhh here is the problem, all normal updates are going through the app store, but not Xamarin. Just open Xamarin Studio on the build host, and check for updates there as well..... Everything works now

    Friday, September 18, 2015 11:58 AM
  • User13824 posted

    @anve, thanks for the heads up! The Mono version was unchanged between the Beta and the Stable release, so there was some little bookkeeping that the team accidentally skipped when adding the package to the Stable channel.

    I have now requested that the team update the summary to match the other installers. It should soon be corrected to say something similar to this:

    Mono is a Stable build to support Apple's iOS 9 Final release. Please see https://blog.xamarin.com/xamarin-for-ios-9-search-deeper/ for more information.

    Friday, September 18, 2015 5:33 PM
  • User130103 posted

    On this page : https://developer.xamarin.com/guides/ios/platform_features/ios9/, it's not recommended to upgrade to xcode 7. Can we now?

    Friday, September 18, 2015 7:16 PM
  • User8164 posted

    We're seeing an issue with HockeyApp and installing builds using iOS 9, the latest Xamarin Studio stable and XCode 7. It sounds very familiar to the issue described here.

    Non-public Bug 33695 - [iOS] Attempting to install a new version of an application on device using a different provisioning profile from the original install is not supported by Xcode 7. Unfortunately, the corresponding error message produced by Xamarin does not describe the problem clearly: "error MT1006: Could not install the application ... on the device ... Application Verification Failed Error (error: 0xe800003a)." This error message will be improved in a future release. Workaround: Manually uninstall the app from the device and try installing it again.

    Unfortunately manually uninstalling the app and installing it again does not resolve the issue. There is currently a separate thread specific to HockeyApp but there isn't much information there yet. https://forums.xamarin.com/discussion/51106/distribution-builds-fail-verification

    As an addendum I downgraded our build server to XCode 6.4 to try and resolve the issue with HockeyApp but unfortunately it is still occurring, so Xamarin.iOS, XCode 6.4 or 7.0 and iOS 9.0 do not allow me to distribute my application through HockeyApp. Everything works fine from Xamarin Studio directly to the device. Next I'm going to attempt to downgrade Xamarin Studio and see if i can start pushing builds to testers again.

    Friday, September 18, 2015 9:20 PM
  • User13824 posted

    @PatrickFinken, yes, you can use Xcode 7 now. Thanks for the heads up! I will notify the documentation team to update that page.

    Friday, September 18, 2015 10:42 PM
  • User13824 posted

    Many thanks for the link ArrenMund. I have now investigated the problem, reproduced it, and added it as a new high priority Bug 34083. More information about the bug, including workarounds, can now be found in the first post in the thread.

    Saturday, September 19, 2015 6:14 AM
  • User80438 posted

    I dunno if it's XF 1.5 or the latest iOS 9 update but since updating to both of these I can not longer access the internet from my app. WebView Url's don't work, nor does HttpClient to access web services. I get this exception with HttpClient.

    App Transport Security has blocked a cleartext HTTP (http://) resource load since it is insecure. Temporary exceptions can be configured via your app's Info.plist file. System.Net.WebException: The resource could not be loaded because the App Transport Security policy requires the use of a sec…

    Is there something else I need to configure now?

    Sunday, September 20, 2015 5:37 PM
  • User80438 posted

    Sorry, forgot to read the notes at the top. Added the NSAppTransportSecurity key and works now :)

    Sunday, September 20, 2015 7:06 PM
  • User31231 posted

    For more information about App Transport Security, please see our documentation on this topic.

    Monday, September 21, 2015 2:07 PM
  • User144147 posted

    my app is 8.3 and my iwatch is 8.2 . the watch simulator doesn't appear, im using the latest stable build

    Monday, September 21, 2015 2:25 PM
  • User8164 posted

    There are a number of users (including us) that are seeing a large collection of storyboard warnings when building with the latest Xamarin Studio. As far as I have seen our app still behaves as expected aside from the warnings.

    See https://forums.xamarin.com/discussion/51104/ios-upgrade-xamarin-now-gives-me-2400-warnings for more information.

    Monday, September 21, 2015 3:45 PM
  • User59275 posted

    With the latest update it seems that a Bug 28299 has resurfaced. I have reported this to the support email above but I am posting here so others users are informed of this.

    There is also another bug which I am getting which is when I create a new iOS Class Library it displays all default reference as not found and compiles with the following error:

    The OutputPath property is not set for project 'ClassLibrary.csproj'. Please check to make sure that you have specified a valid combination of Configuration and Platform for this project. Configuration='Debug' Platform='iPhone'. This error may also appear if some other project is trying to follow a project-to-project reference to this project, this project has been unloaded or is not included in the solution, and the referencing project does not build using the same or an equivalent Configuration or Platform.

    Is anyone else getting this?

    Monday, September 21, 2015 4:07 PM
  • User59275 posted

    Opps sorry the post above should of been posted in the visual studio section. I shall repost there.

    Monday, September 21, 2015 6:01 PM
  • User31385 posted

    I get 9 errors when building in Debug mode for a device using this update, even after applying the Xamarin.iOS hotfix. The errors are all similar to the following:

    Your application is using the 'Contacts' framework, which isn't included in the iOS SDK you're using to build your app (this framework was introduced in iOS 9.0, while you're building with the iOS 8.4 SDK).

    This is very irritating. That framework is very definitely not in our app. It couldn't be, because (as the message states) that API is for iOS 9.0 and I'm building with the 8.4 SDK.

    After applying the hotfix I've also tried a clean, rebuild, and then manually deleting /bin and /obj folders from the project just in case, but the problem remains.

    There are 3 bugs referenced in the hotfix release notes. One of them is inaccessible to me and the others don't describe this issue.

    I see from a bit of research that this bug (MT4134) occurred at the transition between iOS 7 and iOS 8 as well. The advice then was "update your version of Xcode". This is all well and good, but if I do this (i.e. go to Xcode 7) that removes the iOS 7 simulator. We still need to support iOS 7 so upgrading Xcode is not an acceptable workaround. (Quite apart from the time it takes to download Xcode, install it and then wait while it downloads new versions of the simulators).

    I wouldn't mind so much if this was happening on the Alpha or Beta channels. But having it happen on the Stable channel means I've got nowhere to go to get my project working again.

    Monday, September 21, 2015 11:53 PM
  • User13824 posted

    Your application is using the 'Contacts' framework

    Just a very quick little reply to this most recent comment (before I come back to the others), the only change in the hotfix build was to fix the "Can't not find the nested type" error. All three bugs mentioned on the release blog are pure duplicates of that problem. The error "using the 'Contacts' framework" error is something different. It appears you have an email thread started on this error. You should receive a follow-up shortly via that email thread to help Xamarin gather as much information as possible about that error to provide the QA team with the best chances at reproducing it.

    Thanks for the report!

    I've got nowhere to go to get my project working again

    Feel free to request the complete set of download links for Cycle 5 – Service Release 4 in your email support case. The Support Team should be able to send them over quite quickly. That should hopefully get you back up and running. Since you aren't yet using Xcode 7, there isn't much disadvantage in downgrading Xamarin: Xamarin.iOS 9.0 is targeted much more strongly at adding Xcode 7 support on top of Cycle 5 – Service Release 4 rather than fixing bugs.

    Tuesday, September 22, 2015 12:24 AM
  • User13824 posted

    Your application is using the 'Contacts' framework

    One more quick follow-up on this message in case anyone else runs across it: enabling the Xamarin linker to link at least the SDK assemblies should hopefully resolve this problem. The linker is required in this backwards-compatibility scenario due to the way the static registrar works and the fact that Xamarin.iOS 9 itself was compiled using Xcode 7.

    Tuesday, September 22, 2015 3:07 AM
  • User31385 posted

    @BrendanZagaeski following up our offline discussion to post here confirming that enabling Linking for SDKs on the iPhone project enables the project to build for devices once more. The takeaway for future reference is that Xamarin.iOS requires linking to be enabled if the project building for a version of iOS earlier than the version that Xamarin.iOS was built with.

    Since Xamarin.iOS was built with Xcode 7 (i.e. iOS 9 SDK), if I want to build against iOS 8 SDK I must enable linking for the project. I had linking switched off - hence the build failure.

    All good now! Thanks to the Xamarin support team for their rapid response.

    Tuesday, September 22, 2015 4:35 AM
  • User23226 posted

    Yes @StevenTsang - I get the "OutputPath property is not set for project 'ClassLibrary.csproj'" with XVS 3.11.1443 when creating a new iOS Class Library.

    Workaround I use is to edit build path (e.g. "...Debug2") in project properties, save, edit back to original value, save again, then build works.

    Tuesday, September 22, 2015 9:30 AM
  • User13824 posted

    StevenTsang, many thanks for the reports!

    it seems that a Bug 28299 has resurfaced

    The QA team was able to reproduce this, and they have created a new non-public bug 34163 to track it (since it's likely that the root cause of the problem is slightly different even though the end symptom is almost identical).

    I have added that bug to the list of known issues in the first post in the thread to track its resolution status.

    The OutputPath property is not set for project

    The QA team was also able to reproduce this, and they have assigned it to the engineering team to be fixed. I have again added the bug (search for "OutputPath") to the first post in the thread to track its resolution status along with one way to workaround the problem temporarily.

    Tuesday, September 22, 2015 6:42 PM
  • User13824 posted

    ArenMund, thanks for the report!

    I have added non-public Bug 33706 to the first post in the thread to track the status of the upcoming fix that will let Xamarin ignore those unhelpful warning messages from ibtool.

    Tuesday, September 22, 2015 7:05 PM
  • User13824 posted

    my app is 8.3 and my iwatch is 8.2 . the watch simulator doesn't appear, im using the latest stable build

    Henry.8271, if you're still hitting that issue, please send as many details as you can (especially any error messages you might see in the build output, application output, or other logs) in an email to contact+xamarinios9.0@xamarin.com.

    Thanks in advance!

    Tuesday, September 22, 2015 9:05 PM
  • User6965 posted

    I have a storyboard that isn't loading. Works fine in Xcode. Xcode to Xamarin Studio integration works fine.

    Seems that there is an issue parsing the XML. This does contain a View that uses iOS 9 stacks. Is this supported?

    Thanks, Kraig

    Stack Trace


    Tuesday, September 22, 2015 10:31 PM
  • User13824 posted

    @KraigSPEAR, there is one known cause of that "Could not parse xml" error that I have now added to the first post in the thread under non-public bug 34173.

    EDIT: I can confirm that adding a StackView is sufficient to hit this problem in Xamarin Studio 5.9.7. I will update this post again shortly, after I file a bug.

    If you're working in Xamarin Studio, one possible option could be to grab the current Xamarin Studio 5.10 Alpha version. This Alpha version seems to be mostly (if not completely) backwards-compatible with this Xamarin.iOS 9.0 Stable version. The updated iOS designer in Xamarin Studio 5.10 reads the StackView correctly.

    Tuesday, September 22, 2015 11:03 PM
  • User13824 posted

    I double-checked with the iOS designer team on the issue with StackView, and they reminded me that iOS designer support for Xcode 7 is targeted as a follow-up feature for the upcoming Cycle 6 release. (That explains why Xamarin Studio 5.10 works: it is part of the upcoming Cycle 6 release.)

    I have now added a bold note in the first post in the thread about this known limitation because it looks like it is not yet mentioned in the release notes. I will follow-up on having this issue added into the release notes too.

    Thanks again for the report!

    Wednesday, September 23, 2015 12:26 AM
  • User70 posted

    [iOS] [Designer] The Xamarin iOS designer does not yet support Xcode 7 features. Storyboards will fail to load in designer with "There was a problem parsing the XML" when attempting to use new iOS 9 (Xcode 7) designer elements such as StackView. iOS designer support for Xcode 7 features is targeted for the upcoming Cycle 6 feature release. (The preview version of Cycle 6 is currently available in the Alpha channel.) Partial workaround for Xamarin Studio: Right-click the storyboard and choose "Open With -> Xcode Interface Builder".

    I've asked for a feature in the past regarding this, it's in bugzilla somewhere. My request was to allow me to set a XS setting that controls what happens when double-clicking a .storyboard file. I want to use Xcode and stay with Xcode for my storyboarding. Making us right-click to get around the Xamarin driven designer is unfortunate. In Visual Studio we have an Open With option with Set as Default. Something along that line would help in this situation.

    Wednesday, September 23, 2015 12:37 AM
  • User6965 posted

    Thanks Brendan!

    Wednesday, September 23, 2015 12:38 AM
  • User49703 posted

    I'm having this issue trying to upload an 8.4 SDK built binary, compiled with Xamarin.iOS 9 to iTunes Connect:

    ERROR ITMS-90035: "Invalid Signature. A sealed resource is missing or invalid. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose "Clean All" in Xcode, delete the "build" directory in the Finder, and rebuild your release target. For more information, please consult https://developer.apple.com/library/ios/documentation/Security/Conceptual/CodeSigningGuide/Introduction/Introduction.html"

    I'm using the IPA generated by the build process, not the Archive & Publish way. The same build was still working a few days ago, also with Xamarin.iOS 9 and SDK 8.4. So maybe Apple has changed something and other people are now also running into this?

    Edit: Re-tried with Xamarin.iOS 8.10.5, using the IPA from the build process again (after cleaning everything of course) still triggers the same error message that was never there in the first place. Really weird, because using Archive & Packaging allows me to successfully upload the binary again. :confused:

    Wednesday, September 23, 2015 8:28 AM
  • User31231 posted


    I've updated the iOS 9 documentation to include a notice about the Xcode 7 features not currently being supported by the iOS Designer.



    Wednesday, September 23, 2015 1:50 PM
  • User65613 posted

    Well I'm still having the same problem as with the previous release: Xamarin is looking for the VS extensions in the 3.11.458 folder instead of the 1443. Multiple registry value were not updated to the new version so I changed them. I can now work but there are some missing menus in VS and the Xamarin installer keeps saying that the SDK is missing.

    I tried all sorts of uninstallreinstall but nothing works. Is there a way to do a cleanup and clean install?

    Wednesday, September 23, 2015 2:51 PM
  • User13824 posted

    @StefanMoonen, thanks for the report. I have passed on these symptoms to the QA team to have them check if they can reproduce the problem. I will update the thread again as soon as I hear back from them.

    Wednesday, September 23, 2015 5:19 PM
  • User13824 posted

    @Cil, if you haven't come across it before, you can try the steps on the XamarinVS "thorough uninstall" KB article.

    If that doesn't solve the problem, the best next step would be to get in touch with the Support team via email.

    Wednesday, September 23, 2015 5:22 PM
  • User91057 posted

    We got our Xamarin iOS app working in iOS 9 and have run into two issues.

    1. UIDatePicker wasn’t working when we upgraded to iOS 8 and we ended up using SharpMobileCode.ModalPicker as per Xamarin's suggestion and now that doesn’t work. I’ve attached screenshots of it in 8.3 and 9.0. In 9.0, the calendar gets hidden.

    2. UIPickerView isn’t working either. In 9.0, we get an empty list and the same works in 8.3. Attached screenshots of it as well.

    Any help on this is appreciated.

    Wednesday, September 23, 2015 8:02 PM
  • User91057 posted

    SharpMobileCode. DatePicker issue has been fixed as per "https://github.com/SharpMobileCode/ModalPickerViewController/issues/13".

    Wednesday, September 23, 2015 9:28 PM
  • User3516 posted

    I'm using MT.D to design the UI of my app, and have display problems on iPads. See this thread:


    Thursday, September 24, 2015 6:38 AM
  • User29525 posted

    When i open xib file, XCode loads 2 workspace windows. One seems empty, the other has the heading to match the name of the xib. No resources such as Images are available in the Attributes inspector apart from those that are already used by other controls in the XIB. This means I cannot change an image for a new one Also the Assistant Editor finds no code, so that means I cannot apply new outlets or actions to any of the controls in the XIB. This pretty much prevents any tradition Xamarin development for iOS.

    A quick work around or a quick fix would be a life saver.

    Edit : I forgot to mention none of the images are rendered correctly in the View within XCode either.

    Thursday, September 24, 2015 1:59 PM
  • User124099 posted

    web view still now working ? Even I put this one in my plist file: NSAppTransportSecurity NSAllowsArbitraryLoads

    Then I got some html string which has http:// urls inside this string. In iOS <9 it works and can load those html string and be shown in my web view but now ..not working .

    Thursday, September 24, 2015 2:59 PM
  • User65613 posted

    @BrendanZagaeski I'll try it, thanks

    Thursday, September 24, 2015 7:06 PM
  • User41210 posted

    Have same exact issue as Jonathan....any help appreciated

    Thursday, September 24, 2015 9:18 PM
  • User4553 posted

    @Alex.Liu the webview issue is not related to Xamarin. This is by design in iOS 9. If you want a webview that loads insecure websites, you should switch to the new SFSafariViewController.

    Thursday, September 24, 2015 10:50 PM
  • User13824 posted

    @JonathanDibble, @BobLautenbach

    Thanks for the reports. As a quick first attempt at reproducing this problem, I grabbed the HelloWorld_iPhone sample (also attached in a zip on this post in case you'd like to test it).

    Opening the .xib from that solution in Xcode Interface Builder did open 2 windows (I will file a little bug about that), but both windows worked correctly in my case. I closed the extra view for the .xib file, and switched back to the main project view. Then I navigated to the .xib file in the project browser in Xcode and selected it. The assistant was able to find the corresponding .m file, and the attributes inspector was able to find a new .png resource that I added to the project in Xamarin Studio.

    If either of you might have a test case that reproduces the problem you are seeing, please do zip it up and send it to contact+xamarinios9.0@xamarin.com. Feel free to delete the bin, obj, Components, and packages folders before zipping it to save space.

    Thanks in advance!

    Friday, September 25, 2015 3:33 AM
  • User29525 posted

    @BrendanZagaeski, @BobLautenbach. Thanks for the response. I am on my last day at a clients, it is their source code, so I am unable to ship you any examples, and any solution would be to late for the client, such are the pressures of being a commercial developer with a tight timescale.

    I have just noticed while following your post, that I double click on the xib and XCode loads as described earlier, If I close the view of the xib file and scroll through the Project Navigator, I can find the xib file. Opening it from here works perfectly. Images are present, and the Assistant Editor works too. There is obviously an issue linking between Xamarin Studio and XCode. However this process is a useable work around for the time being. Thanks for your help.

    Friday, September 25, 2015 6:52 AM
  • User41210 posted

    @BrendanZagaeski @JonathanDibble Thanks, this workaround helps.

    Friday, September 25, 2015 12:12 PM
  • User3932 posted

    @StefanMoonen, for error ERROR ITMS-90035 (sealed resource) I was able to build a package that could be uploaded by using the Visual Studio build (after correcting alle app icons, still no tight integration in the project files it seems). Before I could not upload a build to Apple.

    Monday, September 28, 2015 1:33 PM
  • User5087 posted

    I have problems to create an ipa file with XS 5.9.7 (build 12). After compiling and creating the package the signing fails with the error "/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Tool exited with code: 1. Output: bin/iPhone/Ad-Hoc/WFPlayeriOS.app: resource envelope is obsolete (custom omit rules) (WF.Player.iOS)". I updated all tools (OS X, XCode) and switched to beta channel. Nothing helps.

    Searching for this error, I found an articel at Stackoverflow which suggest to use "--no-strict" when running codesign. But where could I insert this?

    Wednesday, September 30, 2015 2:22 PM
  • User13824 posted

    Thanks for the report @DirkWeltz. If by chance you might have a test case you could easily share that demonstrates this problem, please do zip it up and email it to contact+xamarinios9.0@xamarin.com, and then leave a message in this thread to let me know. Feel free to delete the bin, obj, Components, and packages folders before zipping it to save space.

    If it is not easy to send a complete test case, then another way to start might be to zip up and send all of the .csproj files from your solution plus the Info.plist from your app project. Those files might contain enough clues to reproduce the problem. Thanks in advance!

    Searching for this error, I found an articel at Stackoverflow which suggest to use "--no-strict" when running codesign. But where could I insert this?

    You could in theory copy the codesign command from the verbose build output, paste it into Terminal.app, and then add the --no-strict argument there.

    But building from Xamarin Studio should work, so the engineers would definitely be interested in a test case, if possible.

    Wednesday, September 30, 2015 9:34 PM
  • User14533 posted

    @DirkWeltz I just ran into the "resource envelope is obsolete" issue and was able to fix it by doing a Clean and a Rebuild.

    Friday, October 2, 2015 1:26 AM
  • User5087 posted

    @BrendanZagaeski: The tip from @Oran (clean and rebuild) worked for me too.

    Friday, October 2, 2015 5:39 AM
  • User27481 posted

    I have a problem on an old app that I need to update , I get the following error: Failed to create App archive. Code signing failed.

    Thursday, October 8, 2015 3:54 PM
  • User13824 posted

    @MarcelaMorales, if you haven't yet resolved this issue, either the "iOS 9 - Service Release 1" Stable channel versions or the "Cycle 6" Alpha channel versions will likely help. In Cycle 6, the "Archive for Publishing" and "Sign and Distribute" actions now use the MSBuild build logic by default. This change should resolve several problems with Classic API apps that affected Xamarin.iOS 9.0.

    In case it might be helpful, another temporary solution could be to downgrade Xcode to 6.4, downgrade Xamarin.iOS to 8.10, and downgrade Xamarin Studio to 5.9.6 (see also "Previous versions, downgrading" on the first post in the thread).

    Saturday, October 17, 2015 3:21 AM
  • User107010 posted

    Enabling Linking did the job for me. Thanks

    Monday, October 19, 2015 10:28 PM