locked
VS 2013 Preview Upgrade done - All extensions installed and working - Deployed - The html is not working.... RRS feed

  • Question

  • Just ready with converting my VS2012 V4 to VS 2013 Preview (Keeping my VS2012 Project backup far away of course).

    Started with 500 errors, ended with 0 and no warnings.

    Have 18 extensions installed, including Devexpress and Component One.

    Just now,  deployed to IIS 7, html not working..

    Everything works great. The client but not the html.

    Back and investigate...


    Sven Elm



    • Edited by Sven Elm Thursday, August 29, 2013 7:17 PM
    • Changed type Sven Elm Thursday, August 29, 2013 7:21 PM
    Thursday, August 29, 2013 6:23 PM

Answers

  • Yeaaaah. Now it's working again.

    Had to remove the app in IIS and re deploy. Maby it left some crap when updating.

    HAPPY again!

    Sven


    Sven Elm

    Thursday, August 29, 2013 7:21 PM
  • Hello Sven, you are correct, there would be some stale files left over in your web app if you didn't first delete the directory contents.  There is a new version of the Publish Wizard available as part of the 2.1 Azure SDK for VS 2013 Preview.  We added a checkbox to the wizard to "Remove additional files at destination".  If this box is checked, the files that are in the target web application folder that are not part of the LS app are deleted during publish.  I will be writing up a blog post about this and some other features added in the 2.1 SDK Publish Wizard.

    David Kidder | Senior SDET | Microsoft | LightSwitch

    • Proposed as answer by Dave KidderModerator Friday, September 6, 2013 1:12 AM
    • Marked as answer by Angie Xu Monday, September 9, 2013 12:59 AM
    Friday, September 6, 2013 1:12 AM
    Moderator

All replies

  • Ok. To fast. Everything works great in my production.....

    Not deployed. Now nothing works ;)

    Back to the Cave, investigating.....

    Sven


    Sven Elm

    Thursday, August 29, 2013 6:29 PM
  • Ok, now the client works, not the html though....

    What the h.....

    Any thoghts anyone...LS team maby??

    Sven


    Sven Elm

    Thursday, August 29, 2013 6:56 PM
  • Yeaaaah. Now it's working again.

    Had to remove the app in IIS and re deploy. Maby it left some crap when updating.

    HAPPY again!

    Sven


    Sven Elm

    Thursday, August 29, 2013 7:21 PM
  • Hi Sven

    Thanks for your quick feeback,

    I'd also like to suggest you to check relevant strategies of deploying LS application,

    # Deploying LightSwitch Applications

    You got a 500 error when you deploy LS application to IIS, you could learn the analisis and resolution about this problem, I think it will be helpful for you to learn the root of this problem,

    Best regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Tuesday, September 3, 2013 8:57 AM
  • Hello Sven, you are correct, there would be some stale files left over in your web app if you didn't first delete the directory contents.  There is a new version of the Publish Wizard available as part of the 2.1 Azure SDK for VS 2013 Preview.  We added a checkbox to the wizard to "Remove additional files at destination".  If this box is checked, the files that are in the target web application folder that are not part of the LS app are deleted during publish.  I will be writing up a blog post about this and some other features added in the 2.1 SDK Publish Wizard.

    David Kidder | Senior SDET | Microsoft | LightSwitch

    • Proposed as answer by Dave KidderModerator Friday, September 6, 2013 1:12 AM
    • Marked as answer by Angie Xu Monday, September 9, 2013 12:59 AM
    Friday, September 6, 2013 1:12 AM
    Moderator