none
SSISDB - Environment variables RRS feed

  • Question

  • Is the environment variables in SSISDB still in use during runtime?  I'm testing a SSIS package call from a pipeline.  It has connection timed out when trying to connect to another Azure SQL DB.  SSISDB is located on a different Azure SQL DB.

    Is this a firewall issue or I need to create a key vault for the connection to work?   Ran a test package querying this the SSISDB locally and it works fine. 

    Friday, July 12, 2019 12:10 AM

All replies

  • If you set environment in SSIS Activity, the variable will be used during execution.

    If you are not using VNet, there is no firewall on IR by default. Could you confirm whether there is firewall on Azure SQL side?

    Friday, July 12, 2019 12:06 PM
  • We are using VNet.    MI and SSISDB are on the same vnet but different subnet.  

    I end up blowing away the DF and IR. Recreate everything and place SSISDB on the MI.  That solved the problem  But I'll still need to circle later to solve the problem.

    Where is SSIS Activity?  Do you mean SSIS Package activity instead?  Does IR uses the environment parameters mapped in SSISDB. The way its done for on-prem?

    • Proposed as answer by xichencx Wednesday, July 17, 2019 2:28 AM
    • Unproposed as answer by xichencx Wednesday, July 17, 2019 2:28 AM
    Monday, July 15, 2019 7:13 PM
  • Here SSIS Activity means "Execute SSIS Package" activity, I suppose you are using ADF UI. You can find this activity in Activities list.

    Yes, if you want to use environment you need to specify the environment in SSISDB. But the UI is different from on-premise. You need to specify it in "Execute SSIS Package" activity. If your IR is on, you can find your packages and environments from dropdown list. If your IR is off, you can input your package path and environment path

    One the environment is specified in activity, its variables will be used during execution


    • Edited by xichencx Wednesday, July 17, 2019 2:31 AM
    Wednesday, July 17, 2019 2:29 AM
  • I found out I was the environment was not mapped under settings.  Which is similar to what you need to do in the job step for SQL Agent jobs.

    However that does not solve my problem. it still uses the values in the package.

    Wednesday, July 17, 2019 8:07 PM