none
How to accept special Characters > and < in EDI Transaction Set Validation RRS feed

  • Question

  • Hi,

    I am trying to have some special characters like > and < in my HD04__PlanCoverageDescription field and got the error

    Invalid character in data element

    I see the base data type for HD04__PlanCoverageDescription is X12_AN. I guess < and > are not valid characters. Can I change X12_AN to other X12 base data type or maybe just to string?

    Anyone has similiar experience? Your advise is highly appreciated.

    Thanks!

    Friday, December 17, 2010 4:08 PM

Answers

  • Hi,

       As long as you are not using < or > char as your delimiters you can change it to X12_ID type and it will pass.

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    • Marked as answer by AndeyZ Monday, December 20, 2010 9:45 PM
    Monday, December 20, 2010 4:04 PM
  • Andey,

    Generally ">" will be used as Component Separator (ISA16), EDI validation engine will try to validate is as Component Separator.

    In your case HD04 does not have a sub element, it may be the reason for your error. 

    Check whether the ISA16 in your EDI file is >, if it's change it as ":" and try processing the file.


    Sathish - http://blog.tsathish.com - Please Indicate "Mark as Answer" if this Post has Answered the Question
    • Marked as answer by AndeyZ Monday, December 20, 2010 9:45 PM
    Friday, December 17, 2010 8:07 PM

All replies

  • Andey,

    Generally ">" will be used as Component Separator (ISA16), EDI validation engine will try to validate is as Component Separator.

    In your case HD04 does not have a sub element, it may be the reason for your error. 

    Check whether the ISA16 in your EDI file is >, if it's change it as ":" and try processing the file.


    Sathish - http://blog.tsathish.com - Please Indicate "Mark as Answer" if this Post has Answered the Question
    • Marked as answer by AndeyZ Monday, December 20, 2010 9:45 PM
    Friday, December 17, 2010 8:07 PM
  • Hi,

       As long as you are not using < or > char as your delimiters you can change it to X12_ID type and it will pass.

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    • Marked as answer by AndeyZ Monday, December 20, 2010 9:45 PM
    Monday, December 20, 2010 4:04 PM
  • Hi,

    Thanks for the hep! I took the advice from both of you. I change the data type to X12_ID and it did pass this time. I also checked the replace separator in payload with |. I am still using > as the ISA16. It did what is supposed to. The ">" is replaced by "|" in the actual data loop. Now the funny thing is when I try to replace separator in payload with different character say:. It still replace ">" with "|". I even update the x12 callback setting and restart the machine. It still does that. Not sure if the replacement value is cached somewhere. Any idea whatelse I need to do if I want to update the replace separator? It seems that BizTalk does not take my new replacement character.

    Thanks for the help!

    Monday, December 20, 2010 5:10 PM
  • Hi Changing the Simple Type to X12_ID alone doesn't work.

    You still have to change the pipeline setting in receive port. In the receive port go to EDI receive and click on elipses next to it.

    Chnage EDI validation = 'false'   (Since you are changing the schema already - I assume you are not worried about EDI validation, especially for Database load for internal purpose)

    Then it works ok!

    Thanks,

    P.S. Gill

    Monday, August 19, 2013 10:54 PM