none
Enable ClearType on WEC700 RRS feed

  • Question

  • Hi guys,

    how can i enable ClearType on WEC700 (iMX51)?

    My first try was a registry item, as WinCE600:

    [HKEY_LOCAL_MACHINE\SYSTEM\GDI\Cleartype]

    Other tries was similar registry items:

    [HKEY_LOCAL_MACHINE\SYSTEM\GDI\ClearTypeSettings]

        "Default"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\GDI\Gamma]

                    "Gamma Value"=dword:000006A4

    We also defined the variable SYSGEN_GPE_CLEARTYPE but no one of the solutions enabled the ClearType :(

    Any idea?


    SteMMo

    Tuesday, September 4, 2012 3:46 PM

Answers

All replies

  • How do you know that ClearType was not "enabled"? You drew some text at different sizes and checked for proper antialiasing? If you choose ClearType as part of your operating system (change the catalog selection) and then do a clean rebuild, you should have ClearType. Note however that ClearType doesn't magically fix all fonts or all resolution issues. If the font you are using is not optimized for ClearType, you may see little if any difference.

    Paul T.

    Tuesday, September 4, 2012 4:25 PM
  • We ran an application on both WinCE600 (with ClearType enabled) and WEC700 (with ClearType?) and the visual feeling is different.

    Where do you can select the ClearType into the catalog? I'm not able to find it ...

    In WinCE600 was enabled by the registry item i reported in the first post.

    We are using Tahoma font (the same used for WinCE600 OS).


    SteMMo

    Tuesday, September 4, 2012 4:38 PM
  • So this is set? By this I mean that I know you tried to set it, but you've verified that the actual registry on the running device is set this way (Remote Registry Editor)? And that it was set on boot?

    http://msdn.microsoft.com/en-us/library/ee482851.aspx

    [HKEY_LOCAL_MACHINE\SYSTEM\GDI\ClearTypeSettings]

        "Default"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\GDI\Gamma]

        "Gamma Value"=dword:000006A4

    My memory must be playing tricks. I remembered there being a ClearType or font smoothing item in the catalog.

    Paul T.

    Tuesday, September 4, 2012 5:15 PM
  • Currently we checked in the registry on both the image and the device and we can confirm that the items are present.

    We also tried surround them with the '; HIVE BOOT SECTION' but without results :(


    SteMMo

    Wednesday, September 5, 2012 8:06 AM
  • Good job. I suppose that you've captured the DEBUG messages and verified that GWES thinks that ClearType is enabled? Sorry its so much trouble!

    Paul T.

    Thursday, September 6, 2012 5:31 PM
  • I captured the DEBUG messages but I found only the message containing the word 'cleartype':

    PID:04230012 TID:04270012 Listview using cleartype

    I don't know if it enough ..


    SteMMo

    Friday, September 7, 2012 8:04 AM
  • The registry keys you're using should be correct according to MSDN (http://msdn.microsoft.com/en-us/library/ee482851.aspx)

    By the way you can use SystemParametersInfo (http://msdn.microsoft.com/en-us/library/ee499131.aspx) to check if ClearType is enabled or not (see

    SPI_GETFONTSMOOTHING). Apparently you can use the same function also to enable ClearType at runtime (see

    SPI_SETFONTSMOOTHING)


    Luca Calligaris lucaDOTcalligarisATeurotechDOTcom www.eurotech.com Check my blog: http://lcalligaris.wordpress.com


    • Edited by Luca Calligaris Friday, September 7, 2012 1:59 PM
    • Marked as answer by SteMMo Wednesday, September 12, 2012 1:00 PM
    Friday, September 7, 2012 1:59 PM
  • I realize, SteMMo, that this thread is 1 1/2 months ago, but did you ever figure this out?

    I'm attempting to get ClearType on both the VirtualPC and eBox3310 platforms, but am not succeeding.  I've put on all the registry values, etc., like you.

    I tried calling SystemParametersInfo with SPI_GETFONTSMOOTHING, but the call is not successful - returns 0.  The GetLastError call indicates error 258, which is "The wait operation timed out".

    Any more hints and tricks that you might have found?

    Thanks.

    Friday, October 26, 2012 8:17 PM
  • jeffcarev,

    I've added to my initial app (run by init registry items) the followind code:

    	// Check ClearType
    	int ct;
    	SystemParametersInfo(SPI_GETFONTSMOOTHING, 0, &ct, 0);
    	RETAILMSG( 1, (L"-> ClearType %d\r\n", ct));
    	if (ct==0) {
    		// If not enabled, do it. 
    		// Under condition to avoid registry write. (TBV)
    		SystemParametersInfo(SPI_SETFONTSMOOTHING, TRUE, 0, 0);
    		SystemParametersInfo(SPI_GETFONTSMOOTHING, 0, &ct, 0);
    		RETAILMSG( 1, (L"-> Forced now %d\r\n", ct));
    	}

    This is good for me: the very first time I read 'ClearType 0' but the next times i read 'ClearType 1', then I guess it was set.


    SteMMo

    Monday, October 29, 2012 9:01 AM
  • Thanks.

    I need to play with the app-level Cleartype setting.  What I had been trying was to get system-level Cleartype which certainly does not seem to work.

    I will go to app level.  (It does make me wonder if getting Cleartype enabled is possible in the standard Microsoft-provided Wordpad app.)

    Thank you, -j

    Monday, October 29, 2012 1:33 PM