locked
MDS web app won't start - server error RRS feed

  • Question

  • Any help to resolve this problem?

    Thanks

    -JO

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed. Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

     

    <!-- Web.Config Configuration File -->

     

    <configuration>

        <system.web>

            <customErrors mode="RemoteOnly"/>

        </system.web>

    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

     

    <!-- Web.Config Configuration File -->

     

    <configuration>

        <system.web>

            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>

        </system.web>

    </configuration>

    Saturday, September 30, 2017 8:07 AM

Answers

  • As mentionned, you need to enable customErrors in your web.config file. depending on your version, this file must be in the following folder:

    C:\Program Files\Microsoft SQL Server\130\Master Data Services\WebApplication.

    <customErrors mode="RemoteOnly"/>

    Once you have enabled customErrors, you will get an explicit error message.

    Most of the time, this error is due to:

    MDSTempDir folder does not exist in the Master Data Services folder: create it and give full control to your MDS Service acoount.

    The MDS service account does not have Read/Write/Full/Control permissions to MDSTempDir

    The MDS service account does not have permissions to web.config file


    • Proposed as answer by AV111Editor Wednesday, February 20, 2019 5:07 AM
    • Marked as answer by AV111Editor Wednesday, February 27, 2019 1:19 PM
    Monday, October 2, 2017 10:03 AM
  • There are indeed two MDSTempDir in the webapplication both need modify right permissions. This is indeed not documented by Microsoft. This error is mentioned in the Error Log in Event Viewer.  Where it points to the right directory which has to few permissions.


    • Edited by Erik_1982 Tuesday, June 26, 2018 8:28 AM
    • Proposed as answer by AV111Editor Tuesday, February 19, 2019 6:06 PM
    • Marked as answer by AV111Editor Wednesday, February 27, 2019 1:19 PM
    Tuesday, June 26, 2018 8:25 AM

All replies

  • As mentionned, you need to enable customErrors in your web.config file. depending on your version, this file must be in the following folder:

    C:\Program Files\Microsoft SQL Server\130\Master Data Services\WebApplication.

    <customErrors mode="RemoteOnly"/>

    Once you have enabled customErrors, you will get an explicit error message.

    Most of the time, this error is due to:

    MDSTempDir folder does not exist in the Master Data Services folder: create it and give full control to your MDS Service acoount.

    The MDS service account does not have Read/Write/Full/Control permissions to MDSTempDir

    The MDS service account does not have permissions to web.config file


    • Proposed as answer by AV111Editor Wednesday, February 20, 2019 5:07 AM
    • Marked as answer by AV111Editor Wednesday, February 27, 2019 1:19 PM
    Monday, October 2, 2017 10:03 AM
  • There are indeed two MDSTempDir in the webapplication both need modify right permissions. This is indeed not documented by Microsoft. This error is mentioned in the Error Log in Event Viewer.  Where it points to the right directory which has to few permissions.


    • Edited by Erik_1982 Tuesday, June 26, 2018 8:28 AM
    • Proposed as answer by AV111Editor Tuesday, February 19, 2019 6:06 PM
    • Marked as answer by AV111Editor Wednesday, February 27, 2019 1:19 PM
    Tuesday, June 26, 2018 8:25 AM