none
Possible socket connection problem Azure IoT Hub RRS feed

  • Question

  • Hello,

    So I've been working on having a non-certified device connect to my Azure IoT Hub. The device supports MQTT protocol w/ TLS as is required, and I've been following this article on connecting a device running C to run MQTT directly.

    The article I've been working from is called "Communicate w/ your IoT hub using the MQTT protocol" it was written in 2018

    I can't link to the article as my account is not yet verified (apparently).

    I've configured my Client ID as "MyCDevice"

    I've configured my User name and Password as specified in the article that I can't include

    and I've added the Baltimore Root Certificate from the IoT Hub SDK from github to my project which includes a "certificates.h" file. 

    I have not tried the paho library method , but I believe that my C program should reliably work for interacting w/ Azure IoT hub.

    When I run my program it comes back with an error which translates to "MQTT_NOT_AUTHORIZED". I don't know if this is a client side issue, or a broker side issue, but any help is appreciated. 

    Thanks

    Friday, August 30, 2019 3:37 PM

All replies