locked
HTTP error 500 Internal Server Error RRS feed

  • Question

  • User524543509 posted

    I'm trying to move over one of my web apps to a new server running IIS7.5  I've installed php and have it fully configured, but for some reason I cant browse to my application.  I get the following error:

    HTTP error 500 - Internal Server error

    C:\php\php-cgi.exe - The FastCGI process exited unxpectedly

    Detailed error info

    Module:  FastCgiModule

    Notification:  ExecuteRequestHandler

    Handler:  ph-5.0.4

    Error Core:  0x0000000ff

    Anyone have any ideas?

    Thursday, September 19, 2013 2:10 PM

All replies

  • User-470603225 posted

    Hi cody,

    It seems that there are some dll extension in your php which are not work properly and force the CGI closed. Try to comment every extensions in php.ini file and see whether the error will exist or not.

    Thursday, September 19, 2013 10:59 PM
  • User524543509 posted

    Well now I'm getting a completely different error.  Maybe a little background will help.  I'm moving this application from a 32bit server to s Server 2008 x64 bit server.  I ended up creating a new application pool and enabled 32-bit applications and assigned the app pool to my application.  The PHP folder under my C: drive is the one I copied over from my 32-bit server.  Is there a different PHP I should be using on ym 64-bit side in order to get my ISAPI modules working correctly? Now Im getting:

    500 internal server error isapimodule php aboMapperCustom 0x800700c1

    Friday, September 20, 2013 2:46 PM