none
McAfee protection pilot v1.0.1 has determined that the NT LM security support provider service in not running in windows 2008 RRS feed

  • Question

  • hi every one
    i came across the problem while installing the mcafee protection pilot 1.0.1,this is the message thrown setup has determined that the NT LM security support provider service in not running. i tried to install in windows server 2008 enterprise edition.
    Saturday, September 19, 2009 5:29 AM

Answers

  • HI,

    You can find the information Regarding the basic requiremnts for installing the McAfee protection pilot v1.0.1
    https://kc.mcafee.com/corporate/index?page=content&id=KB52122

    try these steps

    McAfee ProtectionPilot 1.x
    McAfee ePolicy Orchestrator 3.x.x
    Microsoft Windows Server
    Microsoft MSDE 2000

    Problem 1

    ERROR: Not able to connect to database, when installing ProtectionPilot

    Problem 2

    Unable to install ProtectionPilot

    Problem 3

    A manual installation of a new instance has been successful but ePO/PRP installation still fails

    Problem 4

    The issue is only seen when installing the product and using MSDE

    Cause

    MSDE failed to install because TCPIP protocol and the Named Pipes registry keys are missing. There is already a SQL instance installed but the MSDE instance did not accept connections on the port configured which caused the install of McAfee ProtectionPilot to fail.

    Missing Registry Keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\SuperSocketNetLib\Np]
    "PipeName"="\\\\.\\pipe\\sql\\query"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\SuperSocketNetLib\Tcp]
    "TcpHideFlag"=dword:00000000
    "TcpPort"="1433"
    "TcpDynamicPorts"=""

    Solution

    Use SQL Server Network utility to verify that the TCP/IP and Named Pipes are enabled.

    Verify the registry Keys are present:

    1. Click Start, Run, type regedit and click OK.
    2. Navigate to the following registry key:

      [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\SuperSocketNetLib
    3. Verify that two sub keys are present:  [NP]   [TCP]
    4. Close the registry editor and use the SQL Server Network utility in the next section to correct the problem.

    If the above keys are missing then add/remove the protocols to prepare the registry keys to be repopulated:

    1. Click Start, Run, type svrnetcn and click OK.
    2. In the SQL Server Network utility select the General tab.
    3. Locate the section Enabled protocols.
    4. Verify the following protocols are listed:
      • Named Pipes
      • TCP/IP
    5. Select from the list TCP/IP and click <<Disable. The TCP/IP is removed to the Disabled protocol list.
    6. Select from the list Named Pipes and click <<Disable. The Named Pipes is to the Disabled protocol list.
    7. Click Apply
    8. Click OK when prompted with the message, "You have disabled all the protocols. Super socket Net-Library will not be able to receive requests from the remote clients."
    9. Click OK when prompted with the message, "Any changes made will be saved; however they will not take affect until the SQL Server service is stopped and restarted."
    10. To create the missing NP and TCP registry keys the above protocols must be added again.
    11. Locate the section Disabled protocols.
    12. Select from the list TCP/IP and click Enable>>. The TCP/IP is added to the Enabled protocol list.
    13. Select from the list Named Pipes and click Enable>>. The  Named Pipes is added to the Enabled protocol list.

    Restart the MSSQLSERVER to repopulate the keys:

    1. Click Start, Run, type services.msc and click OK.
    2. Right-click on the following service and select Restart
      • MSSQLSERVER

    Verify the registry Keys have been created:

    1. Click Start, Run, type regedit and click OK.
    2. Navigate to the following registry key:

      [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\SuperSocketNetLib
    3. Verify that two sub keys are present:  [NP]   [TCP]

    Close the registry editor and use the SQL Server Network utility in the next section to verify the protocol settings are correct:

    Verify the properties of Named pipes and TCP/IP  are correct:

    1. Click Start, Run, type svrnetcn and click OK.
      • In the SQL Server Network utility select the General tab.
      • In the section Enabled protocols select the protocol:
        TCP/IP
    2. Click Properties.
    3. Verify that in the field, Default port that the assigned port is:
      1433
    4. Click OK.
    5. In the section Enabled protocols select the protocol:
      Named pipes
    6. Click Properties.
    7. Verify that in the field, Default pipe that the assigned pipe is:
      \\.\pipe\sql\query
    8. Click OK.
    9. Click Apply.
    10. Re-run the McAfee Protection Pilot 1.x setup again to complete the install.


    and you can find the more realavent information in http://forums.mcafeehelp.com/showthread.php?t=222157.

    NOTE - Disclaimer

    The links in this message may lead to third-party Web sites. Microsoft provides third-party resources to help you find customer service and/or technical support resources. Information at these sites may change without notice. Microsoft is not responsible for the content at any third-party Web sites and does not guarantee the accuracy of third-party information.

     

    • Proposed as answer by Anil Inampudi Tuesday, September 29, 2009 5:05 PM
    • Marked as answer by Ragesh_Sys_admin Wednesday, September 30, 2009 9:10 AM
    Monday, September 28, 2009 5:06 PM