How to Suppress "Too Many Spell Errors" in Word Automation RRS feed

  • Question

  • Hi,

    I am using Visual C++ to Automate Word and make it invisible. However, when adding some texts to a Word document, I will see a “Too many spelling errors” message box. I try to set DisplayAlerts to FALSE, as follows:


    But that does not work. The “Spelling error” message will still pop up. How to solve the problem?

    I have posted the same question on stackoverflow for 2 days, but still get no satisfactory answer:


    • Edited by chcw Sunday, July 15, 2018 10:53 PM
    Saturday, July 14, 2018 2:31 AM


  • Hello chcw,

    To be honesty, I know little about C++, I have shared these four options' properties link. Options is a property of app.

    Options.CheckGrammarAsYouType Property

    Options.CheckGrammarWithSpelling Property

    Options.ContextualSpeller Property

    Options.CheckSpellingAsYouType Property

    In VBA, they may looks like

        Application.Options.CheckGrammarAsYouType = False
        Application.Options.CheckGrammarWithSpelling = False
        Application.Options.ContextualSpeller = False
        Application.Options.CheckSpellingAsYouType = False

    I would suggest you confirm these setting could work for you and then try to set them with programming codes. You could manually set these options to check if it could work for you.

    If it could work for you and you still have the issue to set it with C++ programming codes, please feel free to let us know. I will try to involve an engineer who knows C++ into this issue.

    Thanks for understanding,

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact

    • Marked as answer by chcw Friday, July 27, 2018 4:05 AM
    Monday, July 16, 2018 4:22 AM

All replies