none
Register old assembly (Interop.MSFlexGridLib.dll) RRS feed

  • Question

  • I've a program that uses the Interop.MSFlexGridLib.dll assembly and I cannot use gacutil to install in the GAC as it doesn't have a strongly typed name.  If you install the program from my distribution MSI it all works (and run that instance of the exe) it all works fine.  However I changed laptops and have had to re-add my projects references and hence I have found this problem (running VS 2013 on windows 8).

    Does anyone now how I can register the dll in GAC ??

    Urgent that I resolve this so any and all ideas appreciated.

    Thanks, Tim


    Thank you for you time folks!

    • Moved by Amanda Zhu Thursday, January 9, 2014 6:20 AM better forum
    Wednesday, January 8, 2014 10:04 PM

Answers

  • Thanks for the help Hetro.

    I have just resolved the problem in visual studio.  By checking the old project setup (on my previous development machine) I noted that in the properties of the References there are two settings of interest - copy local & Embed Interop Types. 

    By Default Embed Interop Types is set to True and you cannot alter Copy Local.  If you Set Embed Interop Types to false, this enables Copy Local and you can set this value to true.  By copying the file locally to the project on build (i.e. to your debug or release folder) it appears to work in the same way in which the program would upon install with say an MSI.

    having set Copy Local to True everything works just fine!

    Thank you for your support again folks!


    Thank you for you time folks!

    Friday, January 10, 2014 9:56 AM

All replies

  • Hi,

    Visual Studio General Questions forum mainly discusses the usage issue on Visual Studio IDE. Based on your issue, I will move this thread to Common Language Runtime Internals and Architecture forum for better response.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 9, 2014 6:19 AM
  • Hi Tim,

    I guess you must have problem on how to add strong name to the assembly without source code? See the following link for details. http://ryanfarley.com/blog/archive/2010/04/23/sign-a-.net-assembly-with-a-strong-name-without-recompiling.aspx.

    And how to register assembly in GAC: http://msdn.microsoft.com/en-us/library/dkkx7f79(v=vs.110).aspx.

    Hope useful to you.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 10, 2014 3:05 AM
    Moderator
  • Thanks for the help Hetro.

    I have just resolved the problem in visual studio.  By checking the old project setup (on my previous development machine) I noted that in the properties of the References there are two settings of interest - copy local & Embed Interop Types. 

    By Default Embed Interop Types is set to True and you cannot alter Copy Local.  If you Set Embed Interop Types to false, this enables Copy Local and you can set this value to true.  By copying the file locally to the project on build (i.e. to your debug or release folder) it appears to work in the same way in which the program would upon install with say an MSI.

    having set Copy Local to True everything works just fine!

    Thank you for your support again folks!


    Thank you for you time folks!

    Friday, January 10, 2014 9:56 AM