locked
Error 403 after creating a HTTP Handler RRS feed

  • Question

  • User-594738727 posted

    I have followed some of the many instructions on the internet (such as those at: http://support.microsoft.com/kb/308001) to create a custom HTTP handler which basically transmits the file Assessment.pdf to the client whenever they request any page with a .assessment extension.

    <httpHandlers>

    <add verb="*" path="*.assessment" type="COSHH2008.NewHandler"/>

    </httpHandlers>

    First and foremost this works perfectly both in IE and firefox whilst hosted on my development computer.  However upon uploading to my server (IIS V6.0) when accessing an assessment (i.e. 192.168.1.68/example.assessment) I get returned the HTTP error 403.1 Forbidden: Execute access is denied.  With the message "You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed. "

    From my own research I have so far tried:

    • Checking the properties of the site and ensuring Execute Permissions is set to Scripts and Executables
    • Going to configuration and adding the extension .assessment pointing to c:\windows\microsoft.net\framework\v2.0.50727\aspnet_isapi.dll and limit set to "all verbs" and verify file unchecked

    Other than that I am stuck!  Any help would be much appreciated [:D]

    Thursday, February 5, 2009 5:12 AM

Answers

  • User-1136466523 posted

    Hi,

    From your description, it seems that the handler works in your dev envrioment, but fails on your server, right?

    I think it doesn't relate to your applicatioin code, the issue should be caused by the settings of your IIS. Most probably, you have not specified POST in the list of verbs in the scriptmap in IIS/httpHandler in asp.net which maps this handler.

    And the following post maybe helpful to you.

    http://forums.iis.net/t/1149826.aspx

    http://forums.iis.net/p/1148584/1866106.aspx

    Thanks.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, February 9, 2009 11:04 PM