locked
TEE11: Can't authenticate on a Linux version of Eclipse (Hosted TFS11)

    Question

  • Hi,
    I just installed the  the TEE11 plugin for Eclipse on a Linux machine, but I'm not able to authenticate using my Live ID. The 'browser' window does not open and throws an exception.
    To be sure it's just on a non-Windows machine, I installed Eclipse on my Windows 7 machine and also installed TEE11. This did'n give me any problems, and I can successfully connect to my tfspreview account using my Live ID. I think it's something about 'opening a browser windows' on a non-Windows machine?
    On my linux machine:
    On my windows machine
    Any help appreciated!
    Alexander 

    Tuesday, November 29, 2011 9:32 AM

Answers

All replies

  • Solved,

    Ubuntu 11.10 runs with Firefox 7. As from what I found, TEE11 needs an older XULRunner version (xulrunner-1.9.2) to render the Windows Live-ID window used for authentication. Just install xulrunner-1.9.2 (using apt-get), and it should work.

    Will make a blog post for it :-)

    Alexander

    Tuesday, November 29, 2011 10:13 AM
  • I'm glad you figured this out quickly, I was just about to post the same work around.  We finished our TEE 11 CTP before Ubuntu 11.10 was released, and we depend on the Mozilla browser via xulrunner for this control.  Shortly after Ubuntu 11.10 was released, xulrunner wasn't available in the repositories but the xulrunner-1.9.2 from 11.04 installed cleanly and works.

    We're investigating Ubuntu's plans to continue shipping xulrunner in future releases, and may make some changes in our next release to work with the Webkit browser (the default in Eclipse 3.7 on Linux/GTK).

    Tuesday, November 29, 2011 2:41 PM
  • Thanks for the information!

    I made a small blog post about it: http://post.ly/45sSx

     

    Wednesday, November 30, 2011 8:44 PM