none
Visual studio emulator for Android is missing !

    Question

  • I have Visual Studio 2015 community , I installed Xamarin but the emulator for android does not exist on the Tools menu ? Yet my pc is 64 -bit Windows 10. Thanks



    • Edited by Jak_80 Monday, April 11, 2016 2:01 AM
    Monday, April 11, 2016 1:50 AM

Answers

  • Hi Jak,

    Microsoft Emulator runs as a virtual machine on Hyper-V, the virtualization technology for Windows 10.

    For emulator support (Windows or Android), Windows 8.1 (x64) Professional edition or later or Windows 10 Pro or Enterprise (x64) editions are required

    So you need other win 10 edition (Pro or Enterprise) to run the emulator.

    Best Regards,
    Weiwei

    Wednesday, April 13, 2016 2:58 AM
    Moderator
  • My Problem is Solved after migrating my windows Home to Windows Professional , then install the Hyper-V functionality . Thanks for your help 


    • Edited by Jak_80 Thursday, April 14, 2016 9:44 PM
    • Marked as answer by lake XiaoModerator Wednesday, May 18, 2016 12:08 PM
    Wednesday, April 13, 2016 11:45 AM

All replies

  • Hi Jak_80 ,

    Thank you for posting in MSDN forum.

    Actually, Xamarin and android emulator are side by side, although you have install Xamarin, you still need to download the emulator additionally.

    Here is the emulator download link:
    https://www.visualstudio.com/en-us/features/msft-android-emulator-vs.aspx

    Besides, you could install from the setup installer as the following screenshot:


    Best Regards,
    Weiwei

    Tuesday, April 12, 2016 9:31 AM
    Moderator
  • Hello , I have a Windows 10 Home so I did not Hyer -V functionality and saw on the web that we need this functionality so that the emulator works! is it true ?

    Tuesday, April 12, 2016 1:53 PM
  • Hi Jak,

    Microsoft Emulator runs as a virtual machine on Hyper-V, the virtualization technology for Windows 10.

    For emulator support (Windows or Android), Windows 8.1 (x64) Professional edition or later or Windows 10 Pro or Enterprise (x64) editions are required

    So you need other win 10 edition (Pro or Enterprise) to run the emulator.

    Best Regards,
    Weiwei

    Wednesday, April 13, 2016 2:58 AM
    Moderator
  • My Problem is Solved after migrating my windows Home to Windows Professional , then install the Hyper-V functionality . Thanks for your help 


    • Edited by Jak_80 Thursday, April 14, 2016 9:44 PM
    • Marked as answer by lake XiaoModerator Wednesday, May 18, 2016 12:08 PM
    Wednesday, April 13, 2016 11:45 AM
  • Hi Jak,

    If your problem has been resolved, please mark the helpful reply as answer, which is benefit to other communities who has the same problem.

    If any other problem, please feel free to let me know.

    Best Regards,
    Weiwei

    Thursday, April 14, 2016 2:47 AM
    Moderator