none
Multiple menu commands and toolbars suddenly appearing in Visual Studio 2010

    Question

  • On opening VS 2010 to make some changes to an existing project, I find that there are now 4 of each menu command (4 File menus, 4 View menus etc and context menus from RMB are also quadrupled.

    Any idea how this has happened and how to get back to a normal view?

    The menu bar looks like this:-

    File File Edit Edit View View File File Edit Edit View View Project Project Project Project Build Build Debug Debug Team Team Build Build Debug Debug Team Team Data Data Tools Tools Test Test Data Data Tools Tools Test Test .......etc

    This happens when I open VS to start a new project as well.

    My environment is 64-bit Windows 10 upgraded from 8.1 a few months ago. I have been using VS 2010 for 3 or 4 years without incident.


    dshaw


    I had no replies to this, so I have re-installed VS and the problem has gone away. Thanks anyway.
    • Moved by Fred Bao Monday, March 28, 2016 4:57 AM
    • Edited by David Shaw Monday, April 04, 2016 9:22 AM
    Friday, March 25, 2016 1:56 PM

Answers

All replies

  • Hi David,

    This forum is to discuss Data platform development using ADO.NET managed providers, based on your description, it's more related to visual studio General,  we will move your thread to visual studio General forum for better support.

    Best regards,

    Cole Wu

    Monday, March 28, 2016 2:36 AM
  • Hi David Shaw,

    I remember that I met this kind of issue when the VS/Windows Environment got the performance issue.

    (1) Please restart your machine, re-open your VS, check it again.

    (2) Please also run your VS in safe mode, reset your VS settings.

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings.

    devenv /SafeMode: We could know that whether it is related to the add-ins or extension tools.

    (3) Please also install the VS2010 sp1.

    (4) Please also check your task manage, make sure that it is not busy.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 05, 2016 3:01 AM
    Moderator
  • Hi Jack

    Thanks for your thoughts. I had already decided to reinstall VS, and this has worked fine.

    Cheers, and thanks again for taking time to reply.

    David


    dshaw

    Tuesday, April 05, 2016 8:07 AM